summaryrefslogtreecommitdiffstats
path: root/editeng/CppunitTest_editeng_core.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /editeng/CppunitTest_editeng_core.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'editeng/CppunitTest_editeng_core.mk')
-rw-r--r--editeng/CppunitTest_editeng_core.mk79
1 files changed, 79 insertions, 0 deletions
diff --git a/editeng/CppunitTest_editeng_core.mk b/editeng/CppunitTest_editeng_core.mk
new file mode 100644
index 0000000000..9b79048b63
--- /dev/null
+++ b/editeng/CppunitTest_editeng_core.mk
@@ -0,0 +1,79 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,editeng_core))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,editeng_core, \
+ editeng/qa/unit/core-test \
+))
+
+$(eval $(call gb_CppunitTest_use_library_objects,editeng_core,editeng))
+
+$(eval $(call gb_CppunitTest_use_libraries,editeng_core, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ docmodel \
+ i18nlangtag \
+ i18nutil \
+ lng \
+ sal \
+ salhelper \
+ sax \
+ sot \
+ sfx \
+ svl \
+ svt \
+ test \
+ tk \
+ tl \
+ ucbhelper \
+ unotest \
+ utl \
+ vcl \
+ xo \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,editeng_core,\
+ boost_headers \
+ icuuc \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_set_include,editeng_core,\
+ -I$(SRCDIR)/editeng/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,editeng_core))
+
+$(eval $(call gb_CppunitTest_use_ure,editeng_core))
+$(eval $(call gb_CppunitTest_use_vcl,editeng_core))
+
+$(eval $(call gb_CppunitTest_use_components,editeng_core,\
+ configmgr/source/configmgr \
+ framework/util/fwk \
+ i18npool/util/i18npool \
+ i18npool/source/search/i18nsearch \
+ linguistic/source/lng \
+ sfx2/util/sfx \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+ unoxml/source/service/unoxml \
+ sax/source/expatwrap/expwrap \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,editeng_core))
+
+$(eval $(call gb_CppunitTest_use_more_fonts,editeng_core))
+
+# vim: set noet sw=4 ts=4: