summaryrefslogtreecommitdiffstats
path: root/embeddedobj/Library_emboleobj.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /embeddedobj/Library_emboleobj.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'embeddedobj/Library_emboleobj.mk')
-rw-r--r--embeddedobj/Library_emboleobj.mk71
1 files changed, 71 insertions, 0 deletions
diff --git a/embeddedobj/Library_emboleobj.mk b/embeddedobj/Library_emboleobj.mk
new file mode 100644
index 0000000000..d92f86f2c7
--- /dev/null
+++ b/embeddedobj/Library_emboleobj.mk
@@ -0,0 +1,71 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,emboleobj))
+
+$(eval $(call gb_Library_use_custom_headers,emboleobj,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_set_componentfile,emboleobj,embeddedobj/source/msole/emboleobj$(if $(filter WNT,$(OS)),.windows),services))
+
+$(eval $(call gb_Library_set_include,emboleobj,\
+ -I$(SRCDIR)/embeddedobj/source/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_external,emboleobj,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,emboleobj))
+
+$(eval $(call gb_Library_use_libraries,emboleobj,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ utl \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,emboleobj,\
+ embeddedobj/source/msole/closepreventer \
+ embeddedobj/source/msole/oleembed \
+ embeddedobj/source/msole/olemisc \
+ embeddedobj/source/msole/olepersist \
+ embeddedobj/source/msole/olevisual \
+ embeddedobj/source/msole/ownview \
+ embeddedobj/source/msole/xolefactory \
+))
+
+ifeq ($(OS),WNT)
+
+$(eval $(call gb_Library_use_libraries,emboleobj,\
+ embobj \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,emboleobj,\
+ gdi32 \
+ ole32 \
+ oleaut32 \
+ uuid \
+))
+
+$(eval $(call gb_Library_add_exception_objects,emboleobj,\
+ embeddedobj/source/msole/advisesink \
+ embeddedobj/source/msole/graphconvert \
+ embeddedobj/source/msole/olecomponent \
+ embeddedobj/source/msole/olewrapclient \
+ embeddedobj/source/msole/xdialogcreator \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: