summaryrefslogtreecommitdiffstats
path: root/extensions/Library_ldapbe2.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extensions/Library_ldapbe2.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/Library_ldapbe2.mk')
-rw-r--r--extensions/Library_ldapbe2.mk61
1 files changed, 61 insertions, 0 deletions
diff --git a/extensions/Library_ldapbe2.mk b/extensions/Library_ldapbe2.mk
new file mode 100644
index 0000000000..c08ed88f74
--- /dev/null
+++ b/extensions/Library_ldapbe2.mk
@@ -0,0 +1,61 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Library_Library,ldapbe2))
+
+$(eval $(call gb_Library_set_componentfile,ldapbe2,extensions/source/config/ldap/ldapbe2,services))
+
+$(eval $(call gb_Library_use_sdk_api,ldapbe2))
+
+ifneq ($(OS),WNT)
+$(eval $(call gb_Library_add_defs,ldapbe2,\
+ -DLDAP_DEPRECATED \
+))
+endif
+
+$(eval $(call gb_Library_add_exception_objects,ldapbe2,\
+ extensions/source/config/ldap/ldapaccess \
+ extensions/source/config/ldap/ldapuserprofilebe \
+))
+
+$(eval $(call gb_Library_use_libraries,ldapbe2,\
+ comphelper \
+ cppuhelper \
+ cppu \
+ salhelper \
+ sal \
+ tl \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Library_use_externals,ldapbe2,\
+ boost_headers \
+))
+$(eval $(call gb_Library_use_system_win32_libs,ldapbe2,\
+ wldap32 \
+))
+else # 0S!=WNT
+$(eval $(call gb_Library_use_externals,ldapbe2,\
+ boost_headers \
+ openldap \
+ openssl \
+))
+endif
+
+
+
+ifeq ($(OS),FREEBSD)
+$(eval $(call gb_Library_add_libs,ldapbe2,\
+ -lcompat \
+))
+endif # OS=FREEBSD
+
+# vim:set noet sw=4 ts=4: