summaryrefslogtreecommitdiffstats
path: root/extensions/Library_scn.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extensions/Library_scn.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/Library_scn.mk')
-rw-r--r--extensions/Library_scn.mk67
1 files changed, 67 insertions, 0 deletions
diff --git a/extensions/Library_scn.mk b/extensions/Library_scn.mk
new file mode 100644
index 0000000000..51c48fbfdf
--- /dev/null
+++ b/extensions/Library_scn.mk
@@ -0,0 +1,67 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Library_Library,scn))
+
+$(eval $(call gb_Library_use_externals,scn,\
+ boost_headers \
+ $(if $(filter-out WNT,$(OS)),sane_headers) \
+))
+
+$(eval $(call gb_Library_set_include,scn,\
+ -I$(SRCDIR)/extensions/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_set_componentfile,scn,extensions/source/scanner/scn,services))
+
+$(eval $(call gb_Library_use_sdk_api,scn))
+
+$(eval $(call gb_Library_use_libraries,scn,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ $(if $(filter WNT,$(OS)),salhelper) \
+ svt \
+ $(if $(filter WNT,$(OS)),tk) \
+ tl \
+ utl \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,scn,\
+ extensions/source/scanner/scanner \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Library_add_exception_objects,scn,\
+ extensions/source/scanner/scanwin \
+))
+else
+ifneq ($(OS),WNT)
+
+$(eval $(call gb_Library_add_exception_objects,scn,\
+ extensions/source/scanner/grid \
+ extensions/source/scanner/sane \
+ extensions/source/scanner/sanedlg \
+ extensions/source/scanner/scanunx \
+))
+ifeq ($(OS),LINUX)
+$(eval $(call gb_Library_add_libs,scn,\
+ -ldl \
+))
+endif
+endif
+endif
+
+# vim:set noet sw=4 ts=4: