summaryrefslogtreecommitdiffstats
path: root/extensions/Library_updatecheckui.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extensions/Library_updatecheckui.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/Library_updatecheckui.mk')
-rw-r--r--extensions/Library_updatecheckui.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/extensions/Library_updatecheckui.mk b/extensions/Library_updatecheckui.mk
new file mode 100644
index 0000000000..d889defa89
--- /dev/null
+++ b/extensions/Library_updatecheckui.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,updatecheckui))
+
+$(eval $(call gb_Library_set_include,updatecheckui,\
+ -I$(SRCDIR)/extensions/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_set_componentfile,updatecheckui,extensions/source/update/ui/updchk,services))
+
+$(eval $(call gb_Library_use_external,updatecheckui,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,updatecheckui))
+
+$(eval $(call gb_Library_use_libraries,updatecheckui,\
+ vcl \
+ tl \
+ utl \
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+ i18nlangtag \
+))
+
+$(eval $(call gb_Library_add_exception_objects,updatecheckui,\
+ extensions/source/update/ui/updatecheckui \
+))
+
+# vim:set noet sw=4 ts=4: