summaryrefslogtreecommitdiffstats
path: root/extensions/WinResTarget_activex.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extensions/WinResTarget_activex.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/WinResTarget_activex.mk')
-rw-r--r--extensions/WinResTarget_activex.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/extensions/WinResTarget_activex.mk b/extensions/WinResTarget_activex.mk
new file mode 100644
index 0000000000..67980b8773
--- /dev/null
+++ b/extensions/WinResTarget_activex.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_WinResTarget_WinResTarget,so_activex))
+
+$(eval $(call gb_WinResTarget_use_custom_headers,so_activex,\
+ extensions/source/activex/idl \
+))
+
+ifneq ($(ENABLE_DBGUTIL),TRUE)
+$(eval $(call gb_WinResTarget_add_defs,so_activex,\
+ -DPRODUCT \
+))
+endif
+
+$(eval $(call gb_WinResTarget_set_rcfile,so_activex,extensions/source/activex/so_activex))
+
+$(eval $(call gb_WinResTarget_add_defs,so_activex,\
+ $$(DEFS) \
+ -DSO_ACTIVEX_TLB=\"$(subst /,"\\\\",$(WORKDIR)/CustomTarget/extensions/source/activex/idl/so_activex.tlb\") \
+))
+
+# vim:set noet sw=4 ts=4: