summaryrefslogtreecommitdiffstats
path: root/extras/CustomTarget_gallsystem.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extras/CustomTarget_gallsystem.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extras/CustomTarget_gallsystem.mk')
-rw-r--r--extras/CustomTarget_gallsystem.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/extras/CustomTarget_gallsystem.mk b/extras/CustomTarget_gallsystem.mk
new file mode 100644
index 0000000000..434cbb6e17
--- /dev/null
+++ b/extras/CustomTarget_gallsystem.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,extras/gallsysstr))
+
+# bullets, fontwork symbolshapes not listed in ulf/not currently enabled for translation
+$(eval $(call gb_CustomTarget_register_targets,extras/gallsysstr,\
+ $(addsuffix .str,$(filter-out bullets fontwork symbolshapes,$(system_galleries))) \
+))
+
+$(eval $(call gb_CustomTarget_ulfex_rule,\
+ $(call gb_CustomTarget_get_workdir,extras/gallsysstr)/extras_gallsystem.ulf,\
+ $(SRCDIR)/extras/source/gallery/share/gallery_names.ulf,\
+ $(foreach lang,$(gb_TRANS_LANGS),\
+ $(gb_POLOCATION)/$(lang)/extras/source/gallery/share.po)))
+
+# desktop-translate.py is ugly af/doesn't play nice with make dependencies.
+# It expects the target filename to exist and modifies it, so do the hack with own
+# temporary dir
+$(call gb_CustomTarget_get_workdir,extras/gallsysstr)/%.str : \
+ $(call gb_CustomTarget_get_workdir,extras/gallsysstr)/extras_gallsystem.ulf \
+ $(SRCDIR)/extras/source/gallery/gallery_system/dummy.str \
+ $(call gb_ExternalExecutable_get_dependencies,python) \
+ $(SRCDIR)/solenv/bin/desktop-translate.py
+ mkdir -p $(@D)/$* && cp $(SRCDIR)/extras/source/gallery/gallery_system/dummy.str $(@D)/$*/$*.str && \
+ $(call gb_ExternalExecutable_get_command,python) $(SRCDIR)/solenv/bin/desktop-translate.py \
+ --ext "str" -d $(@D)/$*/ $(@D)/extras_gallsystem.ulf && \
+ mv $(@D)/$*/$*.str $@
+
+# vim: set noet sw=4 ts=4: