summaryrefslogtreecommitdiffstats
path: root/extras/Module_extras.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extras/Module_extras.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extras/Module_extras.mk')
-rw-r--r--extras/Module_extras.mk70
1 files changed, 70 insertions, 0 deletions
diff --git a/extras/Module_extras.mk b/extras/Module_extras.mk
new file mode 100644
index 0000000000..497a188cc1
--- /dev/null
+++ b/extras/Module_extras.mk
@@ -0,0 +1,70 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,extras))
+
+$(eval $(call gb_Module_add_targets,extras,\
+ CustomTarget_autocorr \
+ CustomTarget_autotextuser \
+ CustomTarget_glade \
+ CustomTarget_gallsystem \
+ CustomTarget_templates \
+ CustomTarget_tplpresnt \
+ CustomTarget_tplwizard \
+ Package_autocorr \
+ Package_autotextuser \
+ Package_cfgsrvnolang \
+ Package_cfgusr \
+ Package_database \
+ Package_databasebiblio \
+ Package_fonts \
+ Package_resource_fonts \
+ Package_gallbullets \
+ Package_gallmytheme \
+ Package_gallroot \
+ Package_gallsystem \
+ Package_gallsystemstr \
+ Package_glade \
+ Package_labels \
+ $(if $(filter WNT,$(OS)),Package_newfiles) \
+ Package_palettes \
+ Package_tplwizdesktop \
+ Package_wordbook \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,extras,\
+ CustomTarget_autotextshare \
+ AllLangPackage_autotextshare \
+))
+
+ifneq ($(WITH_GALLERY_BUILD),)
+$(eval $(call gb_Module_add_targets,extras,\
+ Gallery_backgrounds \
+ $(call gb_Helper_optional,AVMEDIA,Gallery_sound) \
+))
+endif
+
+ifneq ($(WITH_TEMPLATES),)
+$(eval $(call gb_Module_add_targets,extras,\
+ Package_templates \
+ Package_tplpresnt \
+ Package_tplwizard \
+ Package_tplwizbitmap \
+))
+endif
+
+$(eval $(call gb_Module_add_targets,extras,\
+ Personas \
+))
+
+$(eval $(call gb_Module_add_targets,extras,\
+ CustomTarget_opensymbol \
+))
+
+# vim: set noet sw=4 ts=4: