summaryrefslogtreecommitdiffstats
path: root/extras/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extras/README.md
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extras/README.md')
-rw-r--r--extras/README.md45
1 files changed, 45 insertions, 0 deletions
diff --git a/extras/README.md b/extras/README.md
new file mode 100644
index 0000000000..4c5fbdd2da
--- /dev/null
+++ b/extras/README.md
@@ -0,0 +1,45 @@
+# Extra Modules
+
+Contains templates, clipart galleries, palettes, symbol font, autocorrections, autotexts etc.
+
++ How-to add a new gallery:
+ + create a directory `extras/source/gallery/foo/`
+ + create a `.str` file `extras/source/gallery/foo/foo.str`
+ + add a `foo` section to `extras/source/gallery/share/gallery_names.ulf`
+ + add a `Gallery_foo.mk` at the top-level (and mention in `Module_extra.mk`)
+ + add a new `GALLERY_FILELIST` statement in `scp2/`
+
++ How-to add a new autotext category
+ + create a directory `extras/source/autotext/lang/xx/foo/` where `xx` is your lang code. `xx` must exactly fit with an UI lang code.
+ + unzip your `foo.bau` autotext file in this directory (excluding an empty mimetype file)
+ + add `xx/foo.bau` in `extras/AllLangPackage_autotextshare.mk`
+ + in `extras/CustomTarget_autotextshare.mk`:
+ + add all files contained in `foo.bau` (except mimetype) in `extras_AUTOTEXTSHARE_XMLFILES`
+
++ How-to add a new autotext to an existing category
+ + create a directory `extras/source/autotext/lang/xx/standard/FOO/` to add it in category standard of lang `xx`
+ + add files of the autotext (at least `FOO.xml` for an unformatted autotext)
+ + add autotext name in `extras/source/autotext/lang/xx/standard/BlockList.xml`
+ + add all files of autotext in `extras/source/autotext/lang/xx/standard/META-INF/manifest.xml`
+ + in `extras/CustomTarget_autotextshare.mk`:
+ + add all files of autotext in `extras_AUTOTEXTSHARE_XMLFILES`
+
++ How-to add a new template category
+ + add long category name in TEMPLATE_LONG_NAMES_ARY in sfx2/inc/doctempl.hrc
+ + add short category name in TEMPLATE_SHORT_NAMES_ARY in sfx2/source/doc/doctemplates.cxx
+
++ How-to add a new template to an existing category
+ + clean-up template file as indicated on wiki <https://wiki.documentfoundation.org/Documentation/HowTo/Impress/Make_template_language_independent>
+ + recommendation for settings.xml are given on wiki <https://wiki.documentfoundation.org/Documentation/CompatibilityFlags#Settings_to_include_in_a_new_template>
+ + add `<dc:title>Foo</dc:title>` in `meta.xml` to make presentation name translatable
+ + choose a template category `<Category>`
+ + unzip `Foo.ot?` (? = p, t, s or g) in `extras/source/templates/<Category>/Foo` (no space allowed in any file names)
+ + add `<Category>/Foo.ot? /` in `Package_templates.mk` (or `Package_tplpresnt.mk` if it's a presentation)
+ + in `CustomTarget_templates.mk` (or `CustomTarget_tplpresnt.mk` if it's a presentation):
+ + add `<Category>/Foo/meta.xml /` and all files which are not automatically added in `extras_TEMPLATES_XMLFILES` (or `extras_PRESENTATIONS_XMLFILES` for presentation)
+ + for translation of template name
+ + define a new STR_TEMPLATE_NAMExx in include/sfx2/strings.hrc
+ + define a new STR_TEMPLATE_NAMExx_DEF in sfx2/inc/strings.hxx
+ + in sfx2/source/doc/doctempl.cxx
+ + add STR_TEMPLATE_NAMExx_DEF to aTemplateNames
+ + add STR_TEMPLATE_NAMExx to STR_TEMPLATE_NAME