summaryrefslogtreecommitdiffstats
path: root/filter/Library_icg.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /filter/Library_icg.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'filter/Library_icg.mk')
-rw-r--r--filter/Library_icg.mk60
1 files changed, 60 insertions, 0 deletions
diff --git a/filter/Library_icg.mk b/filter/Library_icg.mk
new file mode 100644
index 0000000000..113faa5a25
--- /dev/null
+++ b/filter/Library_icg.mk
@@ -0,0 +1,60 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,icg))
+
+$(eval $(call gb_Library_set_plugin_for_nodep,icg,sd))
+
+$(eval $(call gb_Library_use_external,icg,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,icg))
+
+$(eval $(call gb_Library_add_defs,icg,\
+ -DFILTER_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_libraries,icg,\
+ comphelper \
+ cppuhelper \
+ tk \
+ vcl \
+ utl \
+ tl \
+ cppu \
+ sal \
+))
+
+$(eval $(call gb_Library_add_exception_objects,icg,\
+ filter/source/graphicfilter/icgm/actimpr \
+ filter/source/graphicfilter/icgm/bitmap \
+ filter/source/graphicfilter/icgm/bundles \
+ filter/source/graphicfilter/icgm/cgm \
+ filter/source/graphicfilter/icgm/chart \
+ filter/source/graphicfilter/icgm/class0 \
+ filter/source/graphicfilter/icgm/class1 \
+ filter/source/graphicfilter/icgm/class2 \
+ filter/source/graphicfilter/icgm/class3 \
+ filter/source/graphicfilter/icgm/class4 \
+ filter/source/graphicfilter/icgm/class5 \
+ filter/source/graphicfilter/icgm/class7 \
+ filter/source/graphicfilter/icgm/classx \
+ filter/source/graphicfilter/icgm/elements \
+))
+
+# vim: set noet sw=4 ts=4: