summaryrefslogtreecommitdiffstats
path: root/filter/Library_msfilter.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /filter/Library_msfilter.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'filter/Library_msfilter.mk')
-rw-r--r--filter/Library_msfilter.mk75
1 files changed, 75 insertions, 0 deletions
diff --git a/filter/Library_msfilter.mk b/filter/Library_msfilter.mk
new file mode 100644
index 0000000000..fcc3435206
--- /dev/null
+++ b/filter/Library_msfilter.mk
@@ -0,0 +1,75 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,msfilter))
+
+$(eval $(call gb_Library_set_componentfile,msfilter,filter/source/msfilter/msfilter,services))
+
+$(eval $(call gb_Library_use_externals,msfilter,\
+ boost_headers \
+ frozen \
+))
+
+$(eval $(call gb_Library_use_sdk_api,msfilter))
+
+$(eval $(call gb_Library_add_defs,msfilter,\
+ -DMSFILTER_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_libraries,msfilter,\
+ svxcore \
+ editeng \
+ sfx \
+ xo \
+ sb \
+ salhelper \
+ svt \
+ tk \
+ vcl \
+ svl \
+ sot \
+ xmlscript \
+ utl \
+ tl \
+ comphelper \
+ basegfx \
+ cppuhelper \
+ cppu \
+ sal \
+))
+
+$(eval $(call gb_Library_add_exception_objects,msfilter,\
+ filter/source/msfilter/countryid \
+ filter/source/msfilter/dffpropset \
+ filter/source/msfilter/dffrecordheader \
+ filter/source/msfilter/escherex \
+ filter/source/msfilter/eschesdo \
+ filter/source/msfilter/mscodec \
+ filter/source/msfilter/msdffimp \
+ filter/source/msfilter/msocximex \
+ filter/source/msfilter/msoleexp \
+ filter/source/msfilter/mstoolbar \
+ filter/source/msfilter/msvbahelper \
+ filter/source/msfilter/svdfppt \
+ filter/source/msfilter/svxmsbas2 \
+ filter/source/msfilter/rtfutil \
+ filter/source/msfilter/util \
+))
+
+# vim: set noet sw=4 ts=4: