summaryrefslogtreecommitdiffstats
path: root/helpcontent2/Package_html_static.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /helpcontent2/Package_html_static.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'helpcontent2/Package_html_static.mk')
-rw-r--r--helpcontent2/Package_html_static.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/helpcontent2/Package_html_static.mk b/helpcontent2/Package_html_static.mk
new file mode 100644
index 0000000000..4ef37566d1
--- /dev/null
+++ b/helpcontent2/Package_html_static.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+# #
+# This file is part of the LibreOffice project.
+# #
+# # This Source Code Form is subject to the terms of the Mozilla Public
+# # License, v. 2.0. If a copy of the MPL was not distributed with this
+# # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+# #
+#
+$(eval $(call gb_Package_Package,helpcontent2_html_static,$(SRCDIR)/helpcontent2/help3xsl))
+
+$(eval $(call gb_Package_add_files,helpcontent2_html_static,$(LIBO_SHARE_HELP_FOLDER),\
+ help.html \
+ $(if $(HELP_ONLINE),index.html) \
+))
+
+$(eval $(call gb_Package_add_file,helpcontent2_html_static,$(LIBO_SHARE_HELP_FOLDER)$(if $(HELP_ONLINE),/$(PRODUCTVERSION))/index.html,index2.html))
+
+$(eval $(call gb_Package_add_files,helpcontent2_html_static,$(LIBO_SHARE_HELP_FOLDER)$(if $(HELP_ONLINE),/$(PRODUCTVERSION)),\
+ a11y-toggle.js \
+ flexsearch.debug.js \
+ help.js \
+ normalize.css \
+ paginathing.js \
+ polyfills.js \
+ prism.js \
+ prism.css \
+))
+
+# vim: set noet sw=4 ts=4: