summaryrefslogtreecommitdiffstats
path: root/hwpfilter/CppunitTest_hwpfilter_test_hwpfilter.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /hwpfilter/CppunitTest_hwpfilter_test_hwpfilter.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'hwpfilter/CppunitTest_hwpfilter_test_hwpfilter.mk')
-rw-r--r--hwpfilter/CppunitTest_hwpfilter_test_hwpfilter.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/hwpfilter/CppunitTest_hwpfilter_test_hwpfilter.mk b/hwpfilter/CppunitTest_hwpfilter_test_hwpfilter.mk
new file mode 100644
index 0000000000..b62abefd7a
--- /dev/null
+++ b/hwpfilter/CppunitTest_hwpfilter_test_hwpfilter.mk
@@ -0,0 +1,43 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,hwpfilter_test_hwpfilter))
+
+$(eval $(call gb_CppunitTest_use_external,hwpfilter_test_hwpfilter,boost_headers))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,hwpfilter_test_hwpfilter, \
+ hwpfilter/qa/cppunit/test_hwpfilter \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,hwpfilter_test_hwpfilter, \
+ ucbhelper \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ test \
+ unotest \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,hwpfilter_test_hwpfilter))
+
+$(eval $(call gb_CppunitTest_use_ure,hwpfilter_test_hwpfilter))
+$(eval $(call gb_CppunitTest_use_vcl,hwpfilter_test_hwpfilter))
+
+$(eval $(call gb_CppunitTest_use_components,hwpfilter_test_hwpfilter,\
+ configmgr/source/configmgr \
+ framework/util/fwk \
+ hwpfilter/source/hwp \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,hwpfilter_test_hwpfilter))
+
+# vim: set noet sw=4 ts=4: