summaryrefslogtreecommitdiffstats
path: root/l10ntools/StaticLibrary_transex.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /l10ntools/StaticLibrary_transex.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'l10ntools/StaticLibrary_transex.mk')
-rw-r--r--l10ntools/StaticLibrary_transex.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/l10ntools/StaticLibrary_transex.mk b/l10ntools/StaticLibrary_transex.mk
new file mode 100644
index 0000000000..57285da944
--- /dev/null
+++ b/l10ntools/StaticLibrary_transex.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,transex))
+
+$(eval $(call gb_StaticLibrary_set_include,transex,\
+ -I$(SRCDIR)/l10ntools/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_StaticLibrary_use_externals,transex,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_StaticLibrary_add_exception_objects,transex,\
+ l10ntools/source/helper \
+ l10ntools/source/common \
+ l10ntools/source/merge \
+ l10ntools/source/po \
+))
+
+# vim: set noet sw=4 ts=4: