summaryrefslogtreecommitdiffstats
path: root/libreofficekit/Executable_tilebench.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /libreofficekit/Executable_tilebench.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libreofficekit/Executable_tilebench.mk')
-rw-r--r--libreofficekit/Executable_tilebench.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/libreofficekit/Executable_tilebench.mk b/libreofficekit/Executable_tilebench.mk
new file mode 100644
index 0000000000..e4a7908dc0
--- /dev/null
+++ b/libreofficekit/Executable_tilebench.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,tilebench))
+
+$(eval $(call gb_Executable_set_include,tilebench,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/desktop/inc \
+))
+
+$(eval $(call gb_Executable_use_externals,tilebench,\
+ boost_headers \
+))
+
+$(eval $(call gb_Executable_use_libraries,tilebench,\
+ sal \
+))
+
+$(eval $(call gb_Executable_add_libs,tilebench,\
+ -lm $(UNIX_DLAPI_LIBS) \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,tilebench,\
+ libreofficekit/qa/tilebench/tilebench \
+))
+
+# vim: set noet sw=4 ts=4: