summaryrefslogtreecommitdiffstats
path: root/libreofficekit/Library_libreofficekitgtk.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /libreofficekit/Library_libreofficekitgtk.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libreofficekit/Library_libreofficekitgtk.mk')
-rw-r--r--libreofficekit/Library_libreofficekitgtk.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/libreofficekit/Library_libreofficekitgtk.mk b/libreofficekit/Library_libreofficekitgtk.mk
new file mode 100644
index 0000000000..4430c03970
--- /dev/null
+++ b/libreofficekit/Library_libreofficekitgtk.mk
@@ -0,0 +1,47 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,libreofficekitgtk))
+
+$(eval $(call gb_Library_use_sdk_api,libreofficekitgtk))
+
+$(eval $(call gb_Library_add_exception_objects,libreofficekitgtk,\
+ libreofficekit/source/gtk/lokdocview \
+ libreofficekit/source/gtk/tilebuffer \
+))
+
+$(eval $(call gb_Library_use_externals,libreofficekitgtk,\
+ boost_headers \
+))
+
+$(eval $(call gb_Library_set_include,libreofficekitgtk,\
+ $$(INCLUDE) \
+ $$(GTK3_CFLAGS) \
+))
+
+$(eval $(call gb_Library_add_libs,libreofficekitgtk,\
+ $(GTK3_LIBS) \
+))
+
+$(eval $(call gb_Library_add_defs,libreofficekitgtk,\
+ -DLOK_PATH="\"$(LIBDIR)/libreoffice/$(LIBO_LIB_FOLDER)\"" \
+ -DLOK_DOC_VIEW_IMPLEMENTATION \
+))
+
+ifeq ($(OS),$(filter LINUX %BSD SOLARIS, $(OS)))
+$(eval $(call gb_Library_add_libs,libreofficekitgtk,\
+ $(UNIX_DLAPI_LIBS) -lm \
+))
+endif
+
+$(eval $(call gb_Library_use_packages,libreofficekitgtk, \
+ libreofficekit_selectionhandles \
+))
+
+# vim: set noet sw=4 ts=4: