summaryrefslogtreecommitdiffstats
path: root/libreofficekit/Module_libreofficekit.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /libreofficekit/Module_libreofficekit.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libreofficekit/Module_libreofficekit.mk')
-rw-r--r--libreofficekit/Module_libreofficekit.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/libreofficekit/Module_libreofficekit.mk b/libreofficekit/Module_libreofficekit.mk
new file mode 100644
index 0000000000..7452b2da3f
--- /dev/null
+++ b/libreofficekit/Module_libreofficekit.mk
@@ -0,0 +1,48 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,libreofficekit))
+
+ifeq ($(OS), $(filter LINUX %BSD SOLARIS, $(OS)))
+
+$(eval $(call gb_Module_add_check_targets,libreofficekit, \
+ CppunitTest_libreofficekit_checkapi \
+))
+
+# tdf#113311 disabled because it can deadlock on shutdown
+#$(eval $(call gb_Module_add_subsequentcheck_targets,libreofficekit,\
+ CppunitTest_libreofficekit_tiledrendering \
+))
+
+ifneq ($(ENABLE_GTK3),)
+$(eval $(call gb_Module_add_targets,libreofficekit,\
+ Library_libreofficekitgtk \
+ Executable_gtktiledviewer \
+))
+endif # ($(ENABLE_GTK3),)
+
+$(eval $(call gb_Module_add_targets,libreofficekit,\
+ $(if $(DISABLE_DYNLOADING),,Executable_tilebench) \
+ Package_selectionhandles \
+ UIConfig_libreofficekit \
+))
+
+else ifeq ($(OS),WNT)
+
+ifneq ($(ENABLE_GTKTILEDVIEWER),)
+$(eval $(call gb_Module_add_targets,libreofficekit,\
+ Library_libreofficekitgtk \
+ Executable_gtktiledviewer \
+ Package_selectionhandles \
+))
+endif
+
+endif
+
+# vim: set ts=4 sw=4 et: