summaryrefslogtreecommitdiffstats
path: root/odk/CppunitTest_odk_checkapi.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /odk/CppunitTest_odk_checkapi.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/CppunitTest_odk_checkapi.mk')
-rw-r--r--odk/CppunitTest_odk_checkapi.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/odk/CppunitTest_odk_checkapi.mk b/odk/CppunitTest_odk_checkapi.mk
new file mode 100644
index 0000000000..22dad8cab6
--- /dev/null
+++ b/odk/CppunitTest_odk_checkapi.mk
@@ -0,0 +1,41 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,odk_checkapi))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,odk_checkapi,\
+ odk/qa/checkapi/checkapi \
+))
+
+$(eval $(call gb_CppunitTest_add_cxxflags,odk_checkapi,\
+ $(gb_CXX03FLAGS) \
+))
+
+$(eval $(call gb_CppunitTest_set_external_code,odk_checkapi))
+
+# The remaining lines must be in the given order, to set up a set of include paths that only
+# contains the instdir SDK include directory, plus SOLARINC as needed for platform-specific
+# includes, plus the workdir sub-directory containing the generated allheaders.hxx and the workdir
+# sub-directory containing the generated UNOIDL include files (which are not bundled in the SDK but
+# would rather get created on demand by the SDK's makefiles), plus whatever is needed for CppUnit:
+
+$(eval $(call gb_CppunitTest_set_include,odk_checkapi, \
+ -I$(INSTDIR)/$(SDKDIRNAME)/include $(SOLARINC)))
+
+$(eval $(call gb_CppunitTest_use_custom_headers,odk_checkapi,\
+ odk/allheaders \
+))
+
+$(eval $(call gb_CppunitTest_use_internal_comprehensive_api,odk_checkapi,\
+ udkapi \
+))
+
+$(eval $(call gb_CppunitTest_use_external,odk_checkapi,cppunit))
+
+# vim: set noet sw=4 ts=4: