summaryrefslogtreecommitdiffstats
path: root/odk/CustomTarget_allheaders.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /odk/CustomTarget_allheaders.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/CustomTarget_allheaders.mk')
-rw-r--r--odk/CustomTarget_allheaders.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/odk/CustomTarget_allheaders.mk b/odk/CustomTarget_allheaders.mk
new file mode 100644
index 0000000000..eb75ec7321
--- /dev/null
+++ b/odk/CustomTarget_allheaders.mk
@@ -0,0 +1,43 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,odk/allheaders))
+
+odk_allheaders_DIR := $(call gb_CustomTarget_get_workdir,odk/allheaders)
+
+$(call gb_CustomTarget_get_target,odk/allheaders) : \
+ $(odk_allheaders_DIR)/allheaders.hxx
+
+define odk_genincludesheader
+// Generated list of sal includes
+#ifdef _WIN32
+#include <windows.h>
+#endif
+
+endef
+
+define odk_geninclude
+$(if $(2),#ifdef _WIN32)
+#include <$(subst $(INSTDIR)/$(SDKDIRNAME)/include/,,$(1))>
+$(if $(2),#endif)
+
+endef
+
+$(odk_allheaders_DIR)/allheaders.hxx : \
+ $(call gb_Package_get_target,odk_headers) \
+ $(call gb_Package_get_target,odk_headers_generated) \
+ | $(odk_allheaders_DIR)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),ECH,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),ECH)
+ $(file >$@,\
+ $(call odk_genincludesheader) \
+ $(foreach file,$(shell cat $^),$(call odk_geninclude,$(file),$(findstring /win32/,$(file)))))
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),ECH)
+
+# vim: set noet sw=4 ts=4: