summaryrefslogtreecommitdiffstats
path: root/odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx')
-rw-r--r--odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx/FirstLoadComponent.cxx148
-rw-r--r--odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx/Makefile100
2 files changed, 248 insertions, 0 deletions
diff --git a/odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx/FirstLoadComponent.cxx b/odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx/FirstLoadComponent.cxx
new file mode 100644
index 0000000000..9ac650ad49
--- /dev/null
+++ b/odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx/FirstLoadComponent.cxx
@@ -0,0 +1,148 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4; fill-column: 100 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ */
+
+#include <iostream>
+#include <sal/main.h>
+#include <cppuhelper/bootstrap.hxx>
+
+#include <com/sun/star/beans/PropertyValue.hpp>
+#include <com/sun/star/beans/XPropertySet.hpp>
+#include <com/sun/star/container/XEnumerationAccess.hpp>
+#include <com/sun/star/container/XEnumeration.hpp>
+#include <com/sun/star/frame/XComponentLoader.hpp>
+#include <com/sun/star/frame/XController.hpp>
+#include <com/sun/star/frame/XModel.hpp>
+#include <com/sun/star/lang/XComponent.hpp>
+#include <com/sun/star/lang/XMultiComponentFactory.hpp>
+#include <com/sun/star/sheet/CellFlags.hpp>
+#include <com/sun/star/sheet/XCellAddressable.hpp>
+#include <com/sun/star/sheet/XCellRangesQuery.hpp>
+#include <com/sun/star/sheet/XSheetCellRanges.hpp>
+#include <com/sun/star/sheet/XSpreadsheetDocument.hpp>
+#include <com/sun/star/sheet/XSpreadsheet.hpp>
+#include <com/sun/star/sheet/XSpreadsheets.hpp>
+#include <com/sun/star/sheet/XSpreadsheetView.hpp>
+#include <com/sun/star/table/CellVertJustify.hpp>
+#include <com/sun/star/table/XCell.hpp>
+#include <com/sun/star/uno/RuntimeException.hpp>
+#include <com/sun/star/uno/Sequence.hxx>
+#include <com/sun/star/uno/Type.hxx>
+#include <com/sun/star/uno/XComponentContext.hpp>
+#include <com/sun/star/uno/XInterface.hpp>
+
+using namespace rtl;
+using namespace cppu;
+using namespace css::uno;
+using namespace css::lang;
+using namespace css::frame;
+using namespace css::container;
+using namespace css::sheet;
+using namespace css::beans;
+using namespace css::table;
+
+SAL_IMPLEMENT_MAIN()
+{
+ try
+ {
+ Reference<XComponentContext> xRemoteContext = bootstrap();
+ if (!xRemoteContext.is())
+ {
+ std::cerr << "ERROR: Could not bootstrap default Office.\n";
+ return 1;
+ }
+
+ Reference<XMultiComponentFactory> xRemoteServiceManager
+ = xRemoteContext->getServiceManager();
+
+ Reference<XInterface> desktop = xRemoteServiceManager->createInstanceWithContext(
+ "com.sun.star.frame.Desktop", xRemoteContext);
+ Reference<XComponentLoader> xComponentLoader
+ = Reference<XComponentLoader>(desktop, UNO_QUERY);
+
+ Sequence<PropertyValue> loadProps(0);
+ Reference<XComponent> xSpreadsheetComponent = xComponentLoader->loadComponentFromURL(
+ "private:factory/scalc", "_blank", 0, loadProps);
+
+ Reference<XSpreadsheetDocument> xSpreadsheetDocument(xSpreadsheetComponent, UNO_QUERY);
+ Reference<XSpreadsheets> xSpreadsheets = xSpreadsheetDocument->getSheets();
+ xSpreadsheets->insertNewByName("MySheet", (sal_Int16)0);
+ Type elemType = xSpreadsheets->getElementType();
+
+ std::cout << elemType.getTypeName() << std::endl;
+ Any sheet = xSpreadsheets->getByName("MySheet");
+ Reference<XSpreadsheet> xSpreadsheet(sheet, UNO_QUERY);
+
+ Reference<XCell> xCell = xSpreadsheet->getCellByPosition(0, 0);
+ xCell->setValue(21);
+ xCell = xSpreadsheet->getCellByPosition(0, 1);
+ xCell->setValue(21);
+ xCell = xSpreadsheet->getCellByPosition(0, 2);
+ xCell->setFormula("=sum(A1:A2)");
+
+ Reference<XPropertySet> xCellProps(xCell, UNO_QUERY);
+ xCellProps->setPropertyValue("CellStyle", Any(OUString("Result")));
+
+ Reference<XModel> xSpreadsheetModel(xSpreadsheetComponent, UNO_QUERY);
+ Reference<XController> xSpreadsheetController = xSpreadsheetModel->getCurrentController();
+ Reference<XSpreadsheetView> xSpreadsheetView(xSpreadsheetController, UNO_QUERY);
+ xSpreadsheetView->setActiveSheet(xSpreadsheet);
+
+ // *********************************************************
+ // example for use of enum types
+ xCellProps->setPropertyValue("VertJustify", Any(CellVertJustify_TOP));
+
+ // *********************************************************
+ // example for a sequence of PropertyValue structs
+ // create an array with one PropertyValue struct, it contains
+ // references only
+ loadProps.realloc(1);
+
+ // instantiate PropertyValue struct and set its member fields
+ PropertyValue asTemplate;
+ asTemplate.Name = "AsTemplate";
+ asTemplate.Value = makeAny(true);
+
+ // assign PropertyValue struct to array of references for PropertyValue
+ // structs
+ loadProps[0] = asTemplate;
+
+ // load calc file as a template
+ // xSpreadsheetComponent = xComponentLoader->loadComponentFromURL(
+ // "file:///c:/temp/DataAnalysys.ods", "_blank", 0, loadProps);
+
+ // *********************************************************
+ // example for use of XEnumerationAccess
+ Reference<XCellRangesQuery> xCellQuery(sheet, UNO_QUERY);
+ Reference<XSheetCellRanges> xFormulaCells
+ = xCellQuery->queryContentCells((sal_Int16)CellFlags::FORMULA);
+ Reference<XEnumerationAccess> xFormulas = xFormulaCells->getCells();
+ Reference<XEnumeration> xFormulaEnum = xFormulas->createEnumeration();
+
+ while (xFormulaEnum->hasMoreElements())
+ {
+ Reference<XCell> formulaCell(xFormulaEnum->nextElement(), UNO_QUERY);
+ Reference<XCellAddressable> xCellAddress(formulaCell, UNO_QUERY);
+ if (xCellAddress.is())
+ {
+ std::cout << "Formula cell in column " << xCellAddress->getCellAddress().Column
+ << ", row " << xCellAddress->getCellAddress().Row << " contains "
+ << formulaCell->getFormula() << std::endl;
+ }
+ }
+ }
+ catch (RuntimeException& e)
+ {
+ std::cerr << e.Message << "\n";
+ return 1;
+ }
+
+ return 0;
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab cinoptions=b1,g0,N-s cinkeys+=0=break: */
diff --git a/odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx/Makefile b/odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx/Makefile
new file mode 100644
index 0000000000..47df3bdc4f
--- /dev/null
+++ b/odk/examples/DevelopersGuide/FirstSteps/FirstLoadComponent/cxx/Makefile
@@ -0,0 +1,100 @@
+#*************************************************************************
+#
+# The Contents of this file are made available subject to the terms of
+# the BSD license.
+#
+# Copyright 2000, 2010 Oracle and/or its affiliates.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+# 3. Neither the name of Sun Microsystems, Inc. nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+# FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+# COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+# BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+# OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
+# TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
+# USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+#**************************************************************************
+
+# Builds the FirstLoadComponent example of the SDK.
+
+PRJ=../../../../..
+SETTINGS=$(PRJ)/settings
+
+include $(SETTINGS)/settings.mk
+include $(SETTINGS)/std.mk
+
+# Define non-platform/compiler specific settings
+APP_NAME=FirstLoadComponent
+
+OUT_APP_INC = $(OUT_INC)/$(APP_NAME)
+OUT_APP_GEN = $(OUT_MISC)/$(APP_NAME)
+OUT_APP_OBJ=$(OUT_OBJ)/$(APP_NAME)
+
+CXXFILES = FirstLoadComponent.cxx
+
+OBJFILES = $(patsubst %.cxx,$(OUT_SLO_COMP)/%.$(OBJ_EXT),$(CXXFILES))
+
+# Targets
+.PHONY: ALL
+ALL : \
+ FirstLoadComponent
+
+include $(SETTINGS)/stdtarget.mk
+
+$(OUT_APP_OBJ)/%.$(OBJ_EXT) : %.cxx $(SDKTYPEFLAG)
+ -$(MKDIR) $(subst /,$(PS),$(@D))
+ $(CC) $(CC_FLAGS) $(CC_INCLUDES) -I$(OUT_APP_INC) $(CC_DEFINES) $(CC_OUTPUT_SWITCH)$(subst /,$(PS),$@) $<
+
+$(OUT_BIN)/_$(APP_NAME)$(EXE_EXT) : $(OUT_APP_OBJ)/$(APP_NAME).$(OBJ_EXT)
+ -$(MKDIR) $(subst /,$(PS),$(@D))
+ -$(MKDIR) $(subst /,$(PS),$(OUT_APP_GEN))
+ifeq "$(OS)" "WIN"
+ $(LINK) $(EXE_LINK_FLAGS) /OUT:$@ /MAP:$(OUT_APP_GEN)/$(basename $(@F)).map \
+ $< $(CPPUHELPERLIB) $(CPPULIB) $(SALHELPERLIB) $(SALLIB)
+else
+ $(LINK) $(EXE_LINK_FLAGS) $(LINK_LIBS) -o $@ $< \
+ $(CPPUHELPERLIB) $(CPPULIB) $(SALHELPERLIB) $(SALLIB) $(STDC++LIB)
+ifeq "$(OS)" "MACOSX"
+ $(INSTALL_NAME_URELIBS_BIN) $@
+endif
+endif
+
+$(OUT_BIN)/$(APP_NAME)$(EXE_EXT) : $(OUT_BIN)/_$(APP_NAME)$(EXE_EXT)
+ -$(MKDIR) $(subst /,$(PS),$(@D))
+ $(COPY) $(subst /,$(PS),$(BIN_DIR)/unoapploader$(EXE_EXT)) $(subst /,$(PS),$@)
+# workaround for touch problem under Windows with full qualified paths
+ make -t $@
+
+FirstLoadComponent : $(OUT_BIN)/$(APP_NAME)$(EXE_EXT)
+ @echo --------------------------------------------------------------------------------
+ @echo Please use the following command to execute the example!
+ @echo -
+ @echo $(MAKE) FirstLoadComponent.run
+ @echo --------------------------------------------------------------------------------
+
+%.run: $(OUT_BIN)/FirstLoadComponent$(EXE_EXT)
+ cd $(subst /,$(PS),$(OUT_BIN)) && $(basename $@)
+
+.PHONY: clean
+clean :
+ -$(DELRECURSIVE) $(subst /,$(PS),$(OUT_APP_INC))
+ -$(DELRECURSIVE) $(subst /,$(PS),$(OUT_APP_GEN))
+ -$(DELRECURSIVE) $(subst /,$(PS),$(OUT_APP_OBJ))
+ -$(DEL) $(subst \\,\,$(subst /,$(PS),$(OUT_BIN)/*FirstLoadComponent*))