summaryrefslogtreecommitdiffstats
path: root/onlineupdate
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /onlineupdate
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'onlineupdate')
-rw-r--r--onlineupdate/CustomTarget_generated.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/onlineupdate/CustomTarget_generated.mk b/onlineupdate/CustomTarget_generated.mk
new file mode 100644
index 0000000000..a4b23562b6
--- /dev/null
+++ b/onlineupdate/CustomTarget_generated.mk
@@ -0,0 +1,45 @@
+<<<<<<< HEAD (5303dd tdf#105844 package: increase PBKDF2 iterations for wholesome)
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,onlineupdate/generated))
+
+onlineupdate_INC := $(call gb_CustomTarget_get_workdir,onlineupdate/generated)/onlineupdate
+
+# For debug purposes, ONLINEUPDATE_MAR_CERTIFICATEDER can be empty, but gen_cert_header.py always
+# expects an existing certificate-der=... pathname, so as a hack fall back to the generated
+# update.ini itself as the pathanme of the certfiicate DER file (though that will cause
+# gen_cert_header.py to generate nonsense data, of course):
+$(call gb_CustomTarget_get_workdir,onlineupdate/generated)/update.ini: | \
+ $(call gb_CustomTarget_get_workdir,onlineupdate/generated)/.dir
+ printf '[Updater]\ncertificate-der=%s\n' '$(or $(ONLINEUPDATE_MAR_CERTIFICATEDER),$@)' > $@
+
+$(onlineupdate_INC)/primaryCert.h : \
+ $(SRCDIR)/onlineupdate/source/update/updater/gen_cert_header.py \
+ $(call gb_ExternalExecutable_get_dependencies,python) \
+ $(call gb_CustomTarget_get_workdir,onlineupdate/generated)/update.ini
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),build,,1)
+ mkdir -p $(dir $@)
+ $(call gb_ExternalExecutable_get_command,python) $(SRCDIR)/onlineupdate/source/update/updater/gen_cert_header.py "primaryCertData" $(call gb_CustomTarget_get_workdir,onlineupdate/generated)/update.ini > $(onlineupdate_INC)/primaryCert.h
+
+$(onlineupdate_INC)/secondaryCert.h : \
+ $(SRCDIR)/onlineupdate/source/update/updater/gen_cert_header.py \
+ $(call gb_ExternalExecutable_get_dependencies,python) \
+ $(call gb_CustomTarget_get_workdir,onlineupdate/generated)/update.ini
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),build,,1)
+ mkdir -p $(dir $@)
+ $(call gb_ExternalExecutable_get_command,python) $(SRCDIR)/onlineupdate/source/update/updater/gen_cert_header.py "secondaryCertData" $(call gb_CustomTarget_get_workdir,onlineupdate/generated)/update.ini > $(onlineupdate_INC)/secondaryCert.h
+
+$(call gb_CustomTarget_get_target,onlineupdate/generated) : \
+ $(onlineupdate_INC)/primaryCert.h \
+ $(onlineupdate_INC)/secondaryCert.h \
+
+# vim: set noet sw=4 ts=4:
+=======
+>>>>>>> CHANGE (3a445c Turn onlineupdate into external/onlineupdate)