summaryrefslogtreecommitdiffstats
path: root/pyuno/Module_pyuno.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /pyuno/Module_pyuno.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyuno/Module_pyuno.mk')
-rw-r--r--pyuno/Module_pyuno.mk62
1 files changed, 62 insertions, 0 deletions
diff --git a/pyuno/Module_pyuno.mk b/pyuno/Module_pyuno.mk
new file mode 100644
index 0000000000..71d7b48e8b
--- /dev/null
+++ b/pyuno/Module_pyuno.mk
@@ -0,0 +1,62 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,pyuno))
+
+ifneq ($(DISABLE_PYTHON),TRUE)
+
+$(eval $(call gb_Module_add_targets,pyuno,\
+ CustomTarget_pyuno_pythonloader_ini \
+ Library_pyuno \
+ Library_pythonloader \
+ Package_python_scripts \
+ Package_pyuno_pythonloader_ini \
+ Rdb_pyuno \
+))
+
+ifneq ($(OS),WNT)
+$(eval $(call gb_Module_add_targets,pyuno,\
+ Library_pyuno_wrapper \
+))
+endif
+
+# Windows: only --enable-python=internal possible
+# python-core: pyuno/python.exe on Windows
+ifeq ($(OS),WNT)
+$(eval $(call gb_Module_add_targets,pyuno,\
+ Executable_python \
+))
+endif
+
+ifeq ($(SYSTEM_PYTHON),)
+
+# python-core: python.sh on Unix
+ifneq ($(OS),WNT)
+$(eval $(call gb_Module_add_targets,pyuno,\
+ CustomTarget_python_shell \
+ Package_python_shell \
+))
+endif
+
+endif # SYSTEM_PYTHON
+
+ifneq ($(OS),MACOSX)
+$(eval $(call gb_Module_add_check_targets,pyuno, \
+ PythonTest_pyuno_pytests_testssl \
+))
+endif
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,pyuno, \
+ PythonTest_pyuno_pytests_testcollections \
+ PythonTest_pyuno_pytests_insertremovecells \
+))
+
+endif # DISABLE_PYTHON
+
+# vim:set noet sw=4 ts=4: