summaryrefslogtreecommitdiffstats
path: root/sal/CppunitTest_Module_DLL.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sal/CppunitTest_Module_DLL.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sal/CppunitTest_Module_DLL.mk')
-rw-r--r--sal/CppunitTest_Module_DLL.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/sal/CppunitTest_Module_DLL.mk b/sal/CppunitTest_Module_DLL.mk
new file mode 100644
index 0000000000..a00429de30
--- /dev/null
+++ b/sal/CppunitTest_Module_DLL.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+# This is not really a test. Only a dynamic library which is loaded by
+# sal_osl_module unit test library.
+
+$(eval $(call gb_CppunitTest_CppunitTest,Module_DLL))
+
+$(eval $(call gb_CppunitTest_set_visibility_default,Module_DLL))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,Module_DLL,\
+ sal/qa/osl/module/osl_Module_DLL \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,Module_DLL,\
+ sal \
+))
+
+# vim: set noet sw=4 ts=4: