summaryrefslogtreecommitdiffstats
path: root/sal/Library_lo-bootstrap.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sal/Library_lo-bootstrap.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sal/Library_lo-bootstrap.mk')
-rw-r--r--sal/Library_lo-bootstrap.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/sal/Library_lo-bootstrap.mk b/sal/Library_lo-bootstrap.mk
new file mode 100644
index 0000000000..1e727cdee4
--- /dev/null
+++ b/sal/Library_lo-bootstrap.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,lo-bootstrap))
+
+ifeq (ANDROID,$(OS))
+
+# We explicitly *don't* want gb_STDLIBS to be linked here
+$(eval $(call gb_Library_disable_standard_system_libs,lo-bootstrap))
+
+$(eval $(call gb_Library_add_libs,lo-bootstrap,\
+ -llog \
+ -landroid \
+))
+
+$(eval $(call gb_Library_add_cobjects,lo-bootstrap,\
+ sal/android/libreofficekit-jni \
+ sal/android/lo-bootstrap \
+))
+endif
+
+ifeq (EMSCRIPTEN,$(OS))
+$(eval $(call gb_Library_add_cobjects,lo-bootstrap,\
+ sal/emscripten/lo-bootstrap \
+))
+endif
+
+$(eval $(call gb_Library_set_include,lo-bootstrap,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/sal/inc \
+))
+
+# vim: set noet sw=4 ts=4: