summaryrefslogtreecommitdiffstats
path: root/sc/Library_scd.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sc/Library_scd.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sc/Library_scd.mk')
-rw-r--r--sc/Library_scd.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/sc/Library_scd.mk b/sc/Library_scd.mk
new file mode 100644
index 0000000000..e330ab66bc
--- /dev/null
+++ b/sc/Library_scd.mk
@@ -0,0 +1,45 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,scd))
+
+$(eval $(call gb_Library_set_componentfile,scd,sc/util/scd,services))
+
+$(eval $(call gb_Library_set_include,scd,\
+ -I$(SRCDIR)/sc/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_external,scd,boost_headers))
+
+$(eval $(call gb_Library_use_common_precompiled_header,scd))
+
+$(eval $(call gb_Library_use_api,scd,\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_Library_use_libraries,scd,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sfx \
+ sot \
+ tl \
+ utl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,scd,\
+ sc/source/ui/unoobj/scdetect \
+ sc/source/ui/unoobj/exceldetect \
+))
+
+# vim: set noet sw=4 ts=4: