summaryrefslogtreecommitdiffstats
path: root/sc/Library_scqahelper.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sc/Library_scqahelper.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sc/Library_scqahelper.mk')
-rw-r--r--sc/Library_scqahelper.mk75
1 files changed, 75 insertions, 0 deletions
diff --git a/sc/Library_scqahelper.mk b/sc/Library_scqahelper.mk
new file mode 100644
index 0000000000..6e8c9eca73
--- /dev/null
+++ b/sc/Library_scqahelper.mk
@@ -0,0 +1,75 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,scqahelper))
+
+$(eval $(call gb_Library_set_include,scqahelper,\
+ -I$(SRCDIR)/sc/inc \
+ -I$(SRCDIR)/sc/source/ui/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_externals,scqahelper, \
+ boost_headers \
+ mdds_headers \
+ cppunit \
+ libxml2 \
+ $(call gb_Helper_optional,OPENCL,clew) \
+))
+
+ifneq ($(SYSTEM_LIBORCUS),)
+$(eval $(call gb_Library_use_externals,scqahelper,orcus))
+else
+$(eval $(call gb_Library_use_externals,scqahelper,orcus-parser))
+endif
+
+$(eval $(call gb_Library_use_common_precompiled_header,scqahelper))
+
+$(eval $(call gb_Library_add_defs,scqahelper,\
+ -DSCQAHELPER_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_api,scqahelper,\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_Library_use_libraries,scqahelper,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ docmodel \
+ editeng \
+ for \
+ sal \
+ sc \
+ sfx \
+ sot \
+ subsequenttest \
+ svl \
+ svt \
+ svx \
+ svxcore \
+ test \
+ tl \
+ unotest \
+ utl \
+ ucbhelper \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,scqahelper,\
+ sc/qa/unit/helper/qahelper \
+ sc/qa/unit/helper/scfiltertestbase \
+ sc/qa/unit/functions_test \
+))
+
+# vim: set noet sw=4 ts=4: