summaryrefslogtreecommitdiffstats
path: root/sc/subsequent_setup.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sc/subsequent_setup.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sc/subsequent_setup.mk')
-rw-r--r--sc/subsequent_setup.mk97
1 files changed, 97 insertions, 0 deletions
diff --git a/sc/subsequent_setup.mk b/sc/subsequent_setup.mk
new file mode 100644
index 0000000000..4cf9b34f98
--- /dev/null
+++ b/sc/subsequent_setup.mk
@@ -0,0 +1,97 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+# template for subsequent tests
+define sc_subsequent_test
+
+$(eval $(call gb_CppunitTest_CppunitTest,sc_subsequent_$(1)))
+
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sc_subsequent_$(1)))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sc_subsequent_$(1), \
+ sc/qa/unit/subsequent_$(1) \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,sc_subsequent_$(1), \
+ boost_headers \
+ mdds_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sc_subsequent_$(1), \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ drawinglayer \
+ docmodel \
+ editeng \
+ for \
+ forui \
+ i18nlangtag \
+ msfilter \
+ oox \
+ sal \
+ salhelper \
+ sax \
+ sc \
+ scqahelper \
+ sfx \
+ sot \
+ subsequenttest \
+ svl \
+ svt \
+ svx \
+ svxcore \
+ test \
+ tk \
+ tl \
+ ucbhelper \
+ unotest \
+ utl \
+ vcl \
+ xo \
+))
+
+$(eval $(call gb_CppunitTest_set_include,sc_subsequent_$(1),\
+ -I$(SRCDIR)/sc/source/ui/inc \
+ -I$(SRCDIR)/sc/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_api,sc_subsequent_$(1),\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,sc_subsequent_$(1)))
+$(eval $(call gb_CppunitTest_use_vcl,sc_subsequent_$(1)))
+
+$(eval $(call gb_CppunitTest_use_rdb,sc_subsequent_$(1),services))
+
+$(eval $(call gb_CppunitTest_use_custom_headers,sc_subsequent_$(1),\
+ officecfg/registry \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,sc_subsequent_$(1)))
+
+$(eval $(call gb_CppunitTest_use_packages,sc_subsequent_$(1), \
+ oox_generated \
+))
+
+$(eval $(call gb_CppunitTest_use_more_fonts,sc_subsequent_$(1)))
+
+$(eval $(call gb_CppunitTest_add_arguments,sc_subsequent_$(1), \
+ -env:arg-env=$(gb_Helper_LIBRARY_PATH_VAR)"$$$${$(gb_Helper_LIBRARY_PATH_VAR)+=$$$$$(gb_Helper_LIBRARY_PATH_VAR)}" \
+))
+
+endef
+
+# vim: set noet sw=4 ts=4: