summaryrefslogtreecommitdiffstats
path: root/scripting/Library_basprov.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /scripting/Library_basprov.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripting/Library_basprov.mk')
-rw-r--r--scripting/Library_basprov.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/scripting/Library_basprov.mk b/scripting/Library_basprov.mk
new file mode 100644
index 0000000000..4170680016
--- /dev/null
+++ b/scripting/Library_basprov.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,basprov))
+
+$(eval $(call gb_Library_set_componentfile,basprov,scripting/source/basprov/basprov,services))
+
+$(eval $(call gb_Library_set_include,basprov,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/scripting/source/inc \
+))
+
+$(eval $(call gb_Library_use_external,basprov,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,basprov))
+
+$(eval $(call gb_Library_use_libraries,basprov,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sb \
+ sfx \
+ svl \
+ tl \
+ ucbhelper \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,basprov,\
+ scripting/source/basprov/baslibnode \
+ scripting/source/basprov/basmethnode \
+ scripting/source/basprov/basmodnode \
+ scripting/source/basprov/basprov \
+ scripting/source/basprov/basscript \
+))
+
+# vim: set noet sw=4 ts=4: