summaryrefslogtreecommitdiffstats
path: root/setup_native/Library_sdqsmsi.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /setup_native/Library_sdqsmsi.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup_native/Library_sdqsmsi.mk')
-rw-r--r--setup_native/Library_sdqsmsi.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/setup_native/Library_sdqsmsi.mk b/setup_native/Library_sdqsmsi.mk
new file mode 100644
index 0000000000..bc769c65b8
--- /dev/null
+++ b/setup_native/Library_sdqsmsi.mk
@@ -0,0 +1,46 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,sdqsmsi))
+
+$(eval $(call gb_Library_add_defs,sdqsmsi,\
+ -U_DLL \
+))
+
+$(eval $(call gb_Library_add_cxxflags,sdqsmsi,\
+ $(if $(MSVC_USE_DEBUG_RUNTIME),/MTd,/MT) \
+ $(if $(filter -fsanitize=%,$(CC)),,/fno-sanitize-address-vcasan-lib) \
+))
+
+$(eval $(call gb_Library_add_ldflags,sdqsmsi,\
+ /DEF:$(SRCDIR)/setup_native/source/win32/customactions/quickstarter/sdqsmsi.def \
+ /NODEFAULTLIB \
+))
+
+$(eval $(call gb_Library_add_exception_objects,sdqsmsi,\
+ setup_native/source/win32/customactions/quickstarter/shutdown_quickstart \
+))
+
+$(eval $(call gb_Library_use_static_libraries,sdqsmsi,\
+ quickstarter \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,sdqsmsi,\
+ libcmt \
+ libcpmt \
+ libucrt \
+ libvcruntime \
+ msi \
+ kernel32 \
+ user32 \
+ advapi32 \
+ shell32 \
+))
+
+# vim: set noet sw=4 ts=4: