summaryrefslogtreecommitdiffstats
path: root/shell/Library_spsupp_x64.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /shell/Library_spsupp_x64.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/Library_spsupp_x64.mk')
-rw-r--r--shell/Library_spsupp_x64.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/shell/Library_spsupp_x64.mk b/shell/Library_spsupp_x64.mk
new file mode 100644
index 0000000000..1988b27455
--- /dev/null
+++ b/shell/Library_spsupp_x64.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,spsupp_x64))
+
+$(eval $(call gb_Library_set_x64,spsupp_x64,YES))
+
+$(eval $(call gb_Library_use_custom_headers,spsupp_x64,\
+ shell/source/win32/spsupp/idl \
+))
+
+$(eval $(call gb_Library_set_include,spsupp_x64,\
+ -I$(SRCDIR)/shell/inc/spsupp \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,spsupp_x64,\
+ advapi32 \
+ kernel32 \
+ ole32 \
+ oleaut32 \
+ user32 \
+))
+
+$(eval $(call gb_Library_add_nativeres,spsupp_x64,spsupp))
+
+$(eval $(call gb_Library_add_ldflags,spsupp_x64,\
+ /DEF:$(SRCDIR)/shell/source/win32/spsupp/spsupp.def \
+))
+
+$(eval $(call gb_Library_add_exception_objects,spsupp_x64,\
+ shell/source/win32/spsupp/COMOpenDocuments_x64 \
+ shell/source/win32/spsupp/registrar_x64 \
+ shell/source/win32/spsupp/spsuppClassFactory_x64 \
+ shell/source/win32/spsupp/spsuppServ_x64 \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: