summaryrefslogtreecommitdiffstats
path: root/shell/WinResTarget_spsupp.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /shell/WinResTarget_spsupp.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/WinResTarget_spsupp.mk')
-rw-r--r--shell/WinResTarget_spsupp.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/shell/WinResTarget_spsupp.mk b/shell/WinResTarget_spsupp.mk
new file mode 100644
index 0000000000..77d9a41342
--- /dev/null
+++ b/shell/WinResTarget_spsupp.mk
@@ -0,0 +1,22 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_WinResTarget_WinResTarget,spsupp))
+
+$(eval $(call gb_WinResTarget_use_custom_headers,spsupp,\
+ shell/source/win32/spsupp/idl \
+))
+
+$(eval $(call gb_WinResTarget_add_defs,spsupp,\
+ -DTLB_FILE=\"$(call gb_CustomTarget_get_workdir,shell/source/win32/spsupp/idl)/spsupp.tlb\" \
+))
+
+$(eval $(call gb_WinResTarget_set_rcfile,spsupp,shell/source/win32/spsupp/res/spsupp))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: