summaryrefslogtreecommitdiffstats
path: root/svl/CppunitTest_svl_qa_cppunit.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /svl/CppunitTest_svl_qa_cppunit.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'svl/CppunitTest_svl_qa_cppunit.mk')
-rw-r--r--svl/CppunitTest_svl_qa_cppunit.mk62
1 files changed, 62 insertions, 0 deletions
diff --git a/svl/CppunitTest_svl_qa_cppunit.mk b/svl/CppunitTest_svl_qa_cppunit.mk
new file mode 100644
index 0000000000..422ff5dea8
--- /dev/null
+++ b/svl/CppunitTest_svl_qa_cppunit.mk
@@ -0,0 +1,62 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,svl_qa_cppunit))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,svl_qa_cppunit))
+
+$(eval $(call gb_CppunitTest_use_externals,svl_qa_cppunit, \
+ boost_headers \
+ icui18n \
+ icuuc \
+ icu_headers \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,svl_qa_cppunit, \
+ svl/qa/unit/svl \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,svl_qa_cppunit, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ sot \
+ svl \
+ tl \
+ unoidl \
+ unotest \
+ utl \
+))
+
+$(eval $(call gb_CppunitTest_set_include,svl_qa_cppunit,\
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_components,svl_qa_cppunit,\
+ i18npool/util/i18npool \
+ configmgr/source/configmgr \
+ framework/util/fwk \
+ lingucomponent/source/numbertext/numbertext \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,svl_qa_cppunit))
+$(eval $(call gb_CppunitTest_use_configuration,svl_qa_cppunit))
+
+# vim: set noet sw=4: