summaryrefslogtreecommitdiffstats
path: root/svtools/CppunitTest_svtools_dialogs_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /svtools/CppunitTest_svtools_dialogs_test.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'svtools/CppunitTest_svtools_dialogs_test.mk')
-rw-r--r--svtools/CppunitTest_svtools_dialogs_test.mk69
1 files changed, 69 insertions, 0 deletions
diff --git a/svtools/CppunitTest_svtools_dialogs_test.mk b/svtools/CppunitTest_svtools_dialogs_test.mk
new file mode 100644
index 0000000000..70f8a00e4b
--- /dev/null
+++ b/svtools/CppunitTest_svtools_dialogs_test.mk
@@ -0,0 +1,69 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitScreenShot,svtools_dialogs_test))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,svtools_dialogs_test, \
+ svtools/qa/unit/svtools-dialogs-test \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,svtools_dialogs_test))
+
+$(eval $(call gb_CppunitTest_set_include,svtools_dialogs_test,\
+ -I$(SRCDIR)/svtools/source/inc \
+ -I$(SRCDIR)/svtools/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,svtools_dialogs_test, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ drawinglayer \
+ editeng \
+ i18nlangtag \
+ i18nutil \
+ msfilter \
+ oox \
+ sal \
+ salhelper \
+ sax \
+ sfx \
+ sot \
+ svl \
+ svt \
+ test \
+ tl \
+ tk \
+ ucbhelper \
+ unotest \
+ utl \
+ vcl \
+ xo \
+))
+
+$(eval $(call gb_CppunitTest_use_external,svtools_dialogs_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,svtools_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_ure,svtools_dialogs_test))
+$(eval $(call gb_CppunitTest_use_vcl_non_headless_with_windows,svtools_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_rdb,svtools_dialogs_test,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,svtools_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_uiconfigs,svtools_dialogs_test,\
+ svt \
+))
+
+# vim: set noet sw=4 ts=4: