summaryrefslogtreecommitdiffstats
path: root/sw/CppunitTest_sw_ooxmlexport8.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sw/CppunitTest_sw_ooxmlexport8.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sw/CppunitTest_sw_ooxmlexport8.mk')
-rw-r--r--sw/CppunitTest_sw_ooxmlexport8.mk81
1 files changed, 81 insertions, 0 deletions
diff --git a/sw/CppunitTest_sw_ooxmlexport8.mk b/sw/CppunitTest_sw_ooxmlexport8.mk
new file mode 100644
index 0000000000..3fa3f70d46
--- /dev/null
+++ b/sw/CppunitTest_sw_ooxmlexport8.mk
@@ -0,0 +1,81 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,sw_ooxmlexport8))
+
+ifneq ($(OS),MACOSX)
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sw_ooxmlexport8))
+endif
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sw_ooxmlexport8, \
+ sw/qa/extras/ooxmlexport/ooxmlexport8 \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sw_ooxmlexport8, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ subsequenttest \
+ test \
+ unotest \
+ utl \
+ sfx \
+ sw \
+ swqahelper \
+ tl \
+ vcl \
+ svxcore \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,sw_ooxmlexport8,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_set_include,sw_ooxmlexport8,\
+ -I$(SRCDIR)/sw/inc \
+ -I$(SRCDIR)/sw/source/core/inc \
+ -I$(SRCDIR)/sw/qa/inc \
+ $$(INCLUDE) \
+))
+
+ifeq ($(OS),MACOSX)
+
+$(eval $(call gb_CppunitTest_add_cxxflags,sw_ooxmlexport8,\
+ $(gb_OBJCXXFLAGS) \
+))
+
+$(eval $(call gb_CppunitTest_use_system_darwin_frameworks,sw_ooxmlexport8,\
+ AppKit \
+))
+
+endif
+
+$(eval $(call gb_CppunitTest_use_api,sw_ooxmlexport8,\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,sw_ooxmlexport8))
+$(eval $(call gb_CppunitTest_use_vcl,sw_ooxmlexport8))
+
+$(eval $(call gb_CppunitTest_use_rdb,sw_ooxmlexport8,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,sw_ooxmlexport8))
+
+$(eval $(call gb_CppunitTest_use_uiconfigs,sw_ooxmlexport8,\
+ modules/swriter \
+))
+
+# vim: set noet sw=4 ts=4: