summaryrefslogtreecommitdiffstats
path: root/sw/CppunitTest_sw_txtimport.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sw/CppunitTest_sw_txtimport.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sw/CppunitTest_sw_txtimport.mk')
-rw-r--r--sw/CppunitTest_sw_txtimport.mk68
1 files changed, 68 insertions, 0 deletions
diff --git a/sw/CppunitTest_sw_txtimport.mk b/sw/CppunitTest_sw_txtimport.mk
new file mode 100644
index 0000000000..1f1cc01a41
--- /dev/null
+++ b/sw/CppunitTest_sw_txtimport.mk
@@ -0,0 +1,68 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,sw_txtimport))
+
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sw_txtimport))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sw_txtimport, \
+ sw/qa/extras/txtimport/txtimport \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sw_txtimport, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ sal \
+ sfx \
+ subsequenttest \
+ sw \
+ swqahelper \
+ test \
+ tl \
+ unotest \
+ utl \
+ vcl \
+ $(gb_UWINAPI) \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,sw_txtimport,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_set_include,sw_txtimport,\
+ -I$(SRCDIR)/sw/inc \
+ -I$(SRCDIR)/sw/source/core/inc \
+ -I$(SRCDIR)/sw/source/uibase/inc \
+ -I$(SRCDIR)/sw/qa/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_api,sw_txtimport,\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,sw_txtimport))
+$(eval $(call gb_CppunitTest_use_vcl,sw_txtimport))
+
+$(eval $(call gb_CppunitTest_use_rdb,sw_txtimport,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,sw_txtimport))
+
+ifneq ($(filter MORE_FONTS,$(BUILD_TYPE)),)
+$(eval $(call gb_CppunitTest_set_non_application_font_use,sw_txtimport,abort))
+endif
+
+# vim: set noet sw=4 ts=4: