summaryrefslogtreecommitdiffstats
path: root/testtools/Module_testtools.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /testtools/Module_testtools.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testtools/Module_testtools.mk')
-rw-r--r--testtools/Module_testtools.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/testtools/Module_testtools.mk b/testtools/Module_testtools.mk
new file mode 100644
index 0000000000..a1b84e175b
--- /dev/null
+++ b/testtools/Module_testtools.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,testtools))
+
+ifeq ($(CROSS_COMPILING),)
+
+$(eval $(call gb_Module_add_targets,testtools,\
+ CustomTarget_bridgetest \
+ InternalUnoApi_bridgetest \
+ InternalUnoApi_performance \
+ Library_cppobj \
+ Library_bridgetest \
+ Library_bridgetest-common \
+ Library_constructors \
+ Rdb_uno_services \
+))
+
+ifneq ($(ENABLE_JAVA),)
+$(eval $(call gb_Module_add_targets,testtools,\
+ Jar_testComponent \
+ CustomTarget_bridgetest_javamaker \
+))
+endif
+
+ifeq ($(COM),MSC)
+$(eval $(call gb_Module_add_targets,testtools,\
+ CustomTarget_bridgetest_climaker \
+))
+endif
+
+$(eval $(call gb_Module_add_check_targets,testtools,\
+ CustomTarget_uno_test \
+))
+
+endif
+
+# vim:set noet sw=4 ts=4: