summaryrefslogtreecommitdiffstats
path: root/toolkit/Module_toolkit.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /toolkit/Module_toolkit.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/Module_toolkit.mk')
-rw-r--r--toolkit/Module_toolkit.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/toolkit/Module_toolkit.mk b/toolkit/Module_toolkit.mk
new file mode 100644
index 0000000000..d039559316
--- /dev/null
+++ b/toolkit/Module_toolkit.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Module_Module,toolkit))
+
+$(eval $(call gb_Module_add_targets,toolkit,\
+ Library_tk \
+))
+
+# FIXME fails on some tinderboxes, needs investigation
+ifneq ($(OS),WNT)
+$(eval $(call gb_Module_add_check_targets,toolkit,\
+ CppunitTest_toolkit \
+ CppunitTest_toolkit_a11y \
+))
+endif
+
+ifneq ($(OOO_JUNIT_JAR),)
+$(eval $(call gb_Module_add_subsequentcheck_targets,toolkit,\
+ JunitTest_toolkit_complex \
+ JunitTest_toolkit_unoapi_1 \
+ JunitTest_toolkit_unoapi_2 \
+ JunitTest_toolkit_unoapi_3 \
+ JunitTest_toolkit_unoapi_4 \
+))
+endif
+
+# vim: set noet sw=4 ts=4: