summaryrefslogtreecommitdiffstats
path: root/ucb/Library_ucpext.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /ucb/Library_ucpext.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ucb/Library_ucpext.mk')
-rw-r--r--ucb/Library_ucpext.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/ucb/Library_ucpext.mk b/ucb/Library_ucpext.mk
new file mode 100644
index 0000000000..563815acc8
--- /dev/null
+++ b/ucb/Library_ucpext.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,ucpext))
+
+$(eval $(call gb_Library_set_componentfile,ucpext,ucb/source/ucp/ext/ucpext,services))
+
+$(eval $(call gb_Library_use_external,ucpext,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,ucpext))
+
+$(eval $(call gb_Library_use_libraries,ucpext,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ tl \
+ ucbhelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,ucpext,\
+ ucb/source/ucp/ext/ucpext_content \
+ ucb/source/ucp/ext/ucpext_datasupplier \
+ ucb/source/ucp/ext/ucpext_provider \
+ ucb/source/ucp/ext/ucpext_resultset \
+))
+
+# vim: set noet sw=4 ts=4: