summaryrefslogtreecommitdiffstats
path: root/unodevtools/Executable_uno-skeletonmaker.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /unodevtools/Executable_uno-skeletonmaker.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unodevtools/Executable_uno-skeletonmaker.mk')
-rw-r--r--unodevtools/Executable_uno-skeletonmaker.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/unodevtools/Executable_uno-skeletonmaker.mk b/unodevtools/Executable_uno-skeletonmaker.mk
new file mode 100644
index 0000000000..87f8d3ca9b
--- /dev/null
+++ b/unodevtools/Executable_uno-skeletonmaker.mk
@@ -0,0 +1,41 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,uno-skeletonmaker))
+
+$(eval $(call gb_Executable_use_external,uno-skeletonmaker,boost_headers))
+
+$(eval $(call gb_Executable_set_include,uno-skeletonmaker,\
+ -I$(SRCDIR)/unodevtools/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Executable_use_libraries,uno-skeletonmaker,\
+ sal \
+ salhelper \
+ unoidl \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,uno-skeletonmaker,\
+ codemaker \
+ codemaker_cpp \
+ codemaker_java \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,uno-skeletonmaker,\
+ unodevtools/source/unodevtools/options \
+ unodevtools/source/skeletonmaker/skeletonmaker \
+ unodevtools/source/skeletonmaker/skeletoncommon \
+ unodevtools/source/skeletonmaker/javatypemaker \
+ unodevtools/source/skeletonmaker/cpptypemaker \
+ unodevtools/source/skeletonmaker/javacompskeleton \
+ unodevtools/source/skeletonmaker/cppcompskeleton \
+))
+
+# vim:set noet sw=4 ts=4: