summaryrefslogtreecommitdiffstats
path: root/unoidl/Executable_unoidl-write.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /unoidl/Executable_unoidl-write.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unoidl/Executable_unoidl-write.mk')
-rw-r--r--unoidl/Executable_unoidl-write.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/unoidl/Executable_unoidl-write.mk b/unoidl/Executable_unoidl-write.mk
new file mode 100644
index 0000000000..e7ec3ba23c
--- /dev/null
+++ b/unoidl/Executable_unoidl-write.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,unoidl-write))
+
+$(eval $(call gb_Executable_add_exception_objects,unoidl-write, \
+ unoidl/source/unoidl-write \
+))
+
+$(eval $(call gb_Executable_use_libraries,unoidl-write, \
+ unoidl \
+ $(if $(filter TRUE,$(DISABLE_DYNLOADING)),reg) \
+ $(if $(filter TRUE,$(DISABLE_DYNLOADING)),store) \
+ salhelper \
+ sal \
+))
+
+ifeq ($(DISABLE_DYNLOADING),TRUE)
+$(eval $(call gb_Executable_use_externals,unoidl-write,\
+ dtoa \
+))
+endif
+
+# vim: set noet sw=4 ts=4: