summaryrefslogtreecommitdiffstats
path: root/unotools/CppunitTest_unotools_configpaths.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /unotools/CppunitTest_unotools_configpaths.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unotools/CppunitTest_unotools_configpaths.mk')
-rw-r--r--unotools/CppunitTest_unotools_configpaths.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/unotools/CppunitTest_unotools_configpaths.mk b/unotools/CppunitTest_unotools_configpaths.mk
new file mode 100644
index 0000000000..d5f002b9bb
--- /dev/null
+++ b/unotools/CppunitTest_unotools_configpaths.mk
@@ -0,0 +1,21 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,unotools_configpaths))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,unotools_configpaths, \
+ unotools/qa/unit/configpaths \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,unotools_configpaths, \
+ sal \
+ utl \
+))
+
+# vim: set noet sw=4 ts=4: