summaryrefslogtreecommitdiffstats
path: root/vcl/CppunitTest_vcl_gtk3_a11y.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /vcl/CppunitTest_vcl_gtk3_a11y.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vcl/CppunitTest_vcl_gtk3_a11y.mk')
-rw-r--r--vcl/CppunitTest_vcl_gtk3_a11y.mk63
1 files changed, 63 insertions, 0 deletions
diff --git a/vcl/CppunitTest_vcl_gtk3_a11y.mk b/vcl/CppunitTest_vcl_gtk3_a11y.mk
new file mode 100644
index 0000000000..476f803344
--- /dev/null
+++ b/vcl/CppunitTest_vcl_gtk3_a11y.mk
@@ -0,0 +1,63 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+# hack plugging into the CppunitTest machinery yet using a xvfb-wrapper GTK3 run
+$(call gb_CppunitTest_get_target,vcl_gtk3_a11y) : gb_TEST_ENV_VARS += SAL_USE_VCLPLUGIN=gtk3
+# force running with the X11 Gdk backend also when running on Wayland
+$(call gb_CppunitTest_get_target,vcl_gtk3_a11y) : gb_TEST_ENV_VARS += GDK_BACKEND=x11
+ifeq (,$(VCL_GTK3_TESTS_NO_XVFB))
+$(call gb_CppunitTest_get_target,vcl_gtk3_a11y) : \
+ ICECREAM_RUN += $(XVFB_RUN) --auto-servernum $(DBUS_LAUNCH) --exit-with-session
+endif
+
+$(eval $(call gb_CppunitTest_CppunitTest,vcl_gtk3_a11y))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,vcl_gtk3_a11y, \
+ vcl/qa/cppunit/a11y/atspi2/atspiwrapper \
+ vcl/qa/cppunit/a11y/atspi2/atspi2 \
+ vcl/qa/cppunit/a11y/atspi2/atspi2text \
+))
+
+$(eval $(call gb_CppunitTest_set_include,vcl_gtk3_a11y,\
+ $$(INCLUDE) \
+ $$(ATSPI2_CFLAGS) \
+))
+
+$(eval $(call gb_CppunitTest_add_libs,vcl_gtk3_a11y,\
+ $$(ATSPI2_LIBS) \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,vcl_gtk3_a11y, \
+ sal \
+ cppu \
+ subsequenttest \
+ test \
+ i18nlangtag \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,vcl_gtk3_a11y,\
+ boost_headers \
+))
+
+$(eval $(call gb_CppunitTest_use_api,vcl_gtk3_a11y,\
+ offapi \
+ udkapi \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,vcl_gtk3_a11y))
+$(eval $(call gb_CppunitTest_use_rdb,vcl_gtk3_a11y,services))
+$(eval $(call gb_CppunitTest_use_ure,vcl_gtk3_a11y))
+$(eval $(call gb_CppunitTest_use_vcl,vcl_gtk3_a11y))
+
+$(eval $(call gb_CppunitTest_use_instdir_configuration,vcl_gtk3_a11y))
+$(eval $(call gb_CppunitTest_use_common_configuration,vcl_gtk3_a11y))
+
+# vim: set noet sw=4 ts=4: