summaryrefslogtreecommitdiffstats
path: root/vcl/CppunitTest_vcl_skia.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /vcl/CppunitTest_vcl_skia.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vcl/CppunitTest_vcl_skia.mk')
-rw-r--r--vcl/CppunitTest_vcl_skia.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/vcl/CppunitTest_vcl_skia.mk b/vcl/CppunitTest_vcl_skia.mk
new file mode 100644
index 0000000000..094bba75fa
--- /dev/null
+++ b/vcl/CppunitTest_vcl_skia.mk
@@ -0,0 +1,51 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,vcl_skia))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,vcl_skia, \
+ vcl/qa/cppunit/skia/skia \
+))
+
+$(eval $(call gb_CppunitTest_set_include,vcl_skia,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/vcl/inc \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,vcl_skia, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sfx \
+ subsequenttest \
+ test \
+ tl \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,vcl_skia, \
+ boost_headers \
+ $(if $(filter SKIA,$(BUILD_TYPE)),skia) \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,vcl_skia))
+
+$(eval $(call gb_CppunitTest_use_ure,vcl_skia))
+$(eval $(call gb_CppunitTest_use_vcl_non_headless,vcl_skia))
+
+$(eval $(call gb_CppunitTest_use_rdb,vcl_skia,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,vcl_skia))
+
+# vim: set noet sw=4 ts=4: