summaryrefslogtreecommitdiffstats
path: root/writerperfect/CppunitTest_writerperfect_stream.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /writerperfect/CppunitTest_writerperfect_stream.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'writerperfect/CppunitTest_writerperfect_stream.mk')
-rw-r--r--writerperfect/CppunitTest_writerperfect_stream.mk59
1 files changed, 59 insertions, 0 deletions
diff --git a/writerperfect/CppunitTest_writerperfect_stream.mk b/writerperfect/CppunitTest_writerperfect_stream.mk
new file mode 100644
index 0000000000..e1e6375312
--- /dev/null
+++ b/writerperfect/CppunitTest_writerperfect_stream.mk
@@ -0,0 +1,59 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,writerperfect_stream))
+
+$(eval $(call gb_CppunitTest_set_include,writerperfect_stream,\
+ -I$(SRCDIR)/writerperfect/source/common \
+ -I$(SRCDIR)/writerperfect/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,writerperfect_stream))
+
+$(eval $(call gb_CppunitTest_use_ure,writerperfect_stream))
+$(eval $(call gb_CppunitTest_use_vcl,writerperfect_stream))
+
+$(eval $(call gb_CppunitTest_use_externals,writerperfect_stream,\
+ boost_headers \
+ revenge \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,writerperfect_stream,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sot \
+ test \
+ tl \
+ ucbhelper \
+ unotest \
+ utl \
+ writerperfect \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,writerperfect_stream))
+
+$(eval $(call gb_CppunitTest_use_components,writerperfect_stream,\
+ configmgr/source/configmgr \
+ i18npool/util/i18npool \
+ package/util/package2 \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+ unotools/util/utl \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,writerperfect_stream,\
+ writerperfect/qa/unit/DirectoryStreamTest \
+ writerperfect/qa/unit/WPXSvStreamTest \
+ writerperfect/qa/unit/stream \
+))
+
+# vim: set noet sw=4 ts=4: