summaryrefslogtreecommitdiffstats
path: root/cli_ure/CliUnoApi_cli_uretypes.mk
diff options
context:
space:
mode:
Diffstat (limited to 'cli_ure/CliUnoApi_cli_uretypes.mk')
-rw-r--r--cli_ure/CliUnoApi_cli_uretypes.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/cli_ure/CliUnoApi_cli_uretypes.mk b/cli_ure/CliUnoApi_cli_uretypes.mk
new file mode 100644
index 0000000000..c8bceb55b2
--- /dev/null
+++ b/cli_ure/CliUnoApi_cli_uretypes.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+include $(SRCDIR)/cli_ure/version/version.txt
+
+$(eval $(call gb_CliUnoApi_CliUnoApi,cli_uretypes))
+
+$(eval $(call gb_CliUnoApi_set_assembly_version,cli_uretypes,$(CLI_URETYPES_NEW_VERSION)))
+
+$(eval $(call gb_CliUnoApi_set_configfile,cli_uretypes,cli_ure/unotypes/cli_uretypes_config,cli_ure/version/version.txt))
+
+$(eval $(call gb_CliUnoApi_set_keyfile,cli_uretypes,$(SRCDIR)/cli_ure/source/cliuno.snk))
+
+$(eval $(call gb_CliUnoApi_set_policy,cli_uretypes,$(CLI_URETYPES_POLICY_ASSEMBLY),$(CLI_URETYPES_POLICY_VERSION)))
+
+$(eval $(call gb_CliUnoApi_wrap_api,cli_uretypes,udkapi))
+
+# vim: set noet sw=4 ts=4: