summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules116
1 files changed, 50 insertions, 66 deletions
diff --git a/debian/rules b/debian/rules
index 30fff1fe51..ef6ee8ec92 100755
--- a/debian/rules
+++ b/debian/rules
@@ -84,7 +84,7 @@ lo_sources_ver=$(shell grep AC_INIT $(SOURCE_TREE)/configure.ac | grep documentf
# NOT in proper libreoffice-3-6 branch
# use ./g checkout -b tag-libreoffice-3.6.2.1 libreoffice-3.6.2.1
GIT_TAG=libreoffice-$(lo_sources_ver)
-GIT_BRANCH=libreoffice-24-2-2
+GIT_BRANCH=libreoffice-24-2-3
endif
ifeq "$(USE_SOURCE_TARBALLS)" "y"
lo_sources_ver=$(shell cat $(CURDIR)/sources.ver | cut -d= -f2)
@@ -245,11 +245,11 @@ ifeq ($(filter noinsttest,$(DEB_BUILD_PROFILES)),)
endif
endif
-ifneq ($(MAKECMDGOALS),build-indep)
+ifneq ($(MAKECMDGOALS),binary-indep)
ENABLE_SYMBOLS=y
SMALL_SYMBOLS=y
endif
-ifeq ($(MAKECMDGOALS),build-indep)
+ifeq ($(MAKECMDGOALS),binary-indep)
# no need to do a double build...
BUILD_NOGUI_PACKAGES=n
# go sure
@@ -298,7 +298,6 @@ else
PACKAGE_SDK_DOCS=y
endif
PACKAGE_LOKIT=y
-ENABLE_CHART_TESTS=n
# will not work, uses schema/ stripped in the tarballs
ifeq "$(USE_SOURCE_TARBALLS)" "y"
ENABLE_EXPORT_VALIDATION_TESTS=n
@@ -459,13 +458,8 @@ SYSTEM_STUFF += libtiff
SYSTEM_STUFF += frozen
SYSTEM_STUFF += argon2
-# override stuff for build-indep to save build dependencies
-# This is a hack. dpkg calls build-indep for -A so this is in effect.
-# but for the binary target it calls binary-indep which calls install etc
-# apparently without these. so those guards do not work if stuff is moved
-# in install-common. e.g. qt/kf5, firebird_sdbc.xcd. Those need to be guarded
-# with an if [ -f or similar
-ifeq ($(MAKECMDGOALS),build-indep)
+# override stuff for indep builds to save build dependencies
+ifeq ($(MAKECMDGOALS),binary-indep)
ENABLE_EVOAB=n
BUILD_GTK3=n
ENABLE_INTROSPECTION=n
@@ -663,13 +657,16 @@ ifneq (nocheck,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
endif
IGNORE_MAKE_FAILURES=-
TEST_TIMEOUT := timeout --foreground --preserve-status -v -k 250m 200m
- ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),$(OOO_CHECK_FATAL_ARCHS)))
+ ifeq "$(RUN_MAKE_CHECK)" "y"
+ ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),$(OOO_CHECK_FATAL_ARCHS)))
IGNORE_MAKE_FAILURES:=
TEST_TIMEOUT:=
- endif
- ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),$(OOO_SMOKETEST_FATAL_ARCHS)))
+ endif
+ else
+ ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),$(OOO_SMOKETEST_FATAL_ARCHS)))
IGNORE_MAKE_FAILURES:=
TEST_TIMEOUT:=
+ endif
endif
endif
ifeq "$(RUN_MAKE_CHECK)" "y"
@@ -752,7 +749,7 @@ DEBHELPER_OPTIONS += -Nlibreoffice-core-nogui -Nlibreoffice-calc-nogui -Nlibreof
endif
ifeq "$(AUTOPKGTEST_BUILD)" "y"
-# as above (for build-indep), no need to do two builds here...
+# as above (for binary-indep), no need to do two builds here...
# needs to be here since there is arch-specific rules before
BUILD_NOGUI_PACKAGES=n
# go sure
@@ -1013,7 +1010,9 @@ endif
ifneq (,$(filter xmlsec, $(SYSTEM_STUFF)))
BUILD_DEPS += , libxmlsec1-dev (>= 1.2.35)
ifneq ($(BOOKWORM_BACKPORT),y)
- BUILD_DEPS += , libxmlsec1-dev (>= 1.2.39-5) [$(filter $(OOO_CHECK_ARCHS),$(filter-out i386,$(OOO_32BIT_ARCHS)))] <!nocheck>
+ ifneq (,$(filter $(OOO_CHECK_ARCHS),$(filter-out i386,$(OOO_32BIT_ARCHS))))
+ BUILD_DEPS_ARCH += , libxmlsec1-dev (>= 1.2.39-5) [$(filter $(OOO_CHECK_ARCHS),$(filter-out i386,$(OOO_32BIT_ARCHS)))] <!nocheck>
+ endif
endif
endif
ifneq (,$(filter expat, $(SYSTEM_STUFF)))
@@ -1197,7 +1196,7 @@ endif
BUILD_DEPS_ARCH += , libcppunit-dev (>= 1.15.1-4) [$(filter $(OOO_CHECK_ARCHS),$(OOO_ARCHS))] <!nocheck>
endif
endif
- ifeq ($(MAKECMDGOALS),build-indep)
+ ifeq ($(MAKECMDGOALS),binary-indep)
CONFIGURE_FLAGS_INDEP += --without-cppunit
endif
endif
@@ -1206,9 +1205,6 @@ endif
else
CONFIGURE_FLAGS += --without-junit
endif
- ifeq "$(ENABLE_CHART_TESTS)" "y"
- CONFIGURE_FLAGS += --enable-chart-tests
- endif
ifeq "$(ENABLE_EXPORT_VALIDATION_TESTS)" "y"
BUILD_DEPS += , libofficeotron-java$(OOO_NO_CHECK_ARCHS) <!nocheck !nojava>, libodfvalidator-java$(OOO_NO_CHECK_ARCHS) <!nocheck !nojava>
else
@@ -1392,7 +1388,9 @@ endif
ifneq (,$(filter orcus, $(SYSTEM_STUFF)))
BUILD_DEPS += , liborcus-dev (>= 0.19.1), liborcus-dev (<< 0.20~)
ifneq ($(BOOKWORM_BACKPORT),y)
- BUILD_DEPS += , liborcus-dev (>> 0.19.2-3+b1) [$(filter $(OOO_CHECK_ARCHS),$(filter-out i386,$(OOO_32BIT_ARCHS)))] <!nocheck>
+ ifneq (,$(filter $(OOO_CHECK_ARCHS),$(filter-out i386,$(OOO_32BIT_ARCHS))))
+ BUILD_DEPS_ARCH += , liborcus-dev (>> 0.19.2-3+b1) [$(filter $(OOO_CHECK_ARCHS),$(filter-out i386,$(OOO_32BIT_ARCHS)))] <!nocheck>
+ endif
endif
endif
@@ -2224,17 +2222,6 @@ endif
$(PYTHON) debian/scripts/joinctrl.py < debian/control.new > debian/control.tmp
mv debian/control.tmp debian/control.new
- # make -l10n-fi suggest libreoffice-spellcheck-fi to
- # match myspell-fi and libreoffice-soikko/-voikko
- perl -pi -e 's/myspell-dictionary-fi/myspell-dictionary-fi | libreoffice-spellcheck-fi/' debian/control.new
- perl -pi -e 's/hyphen-fi/hyphen-fi | libreoffice-hyphenation-fi/' debian/control.new
- # similar for -l10n-tr and zemberek
- perl -pi -e 's/myspell-dictionary-tr/myspell-dictionary-tr | libreoffice-spellcheck-tr/' debian/control.new
- perl -pi -e 's/hyphen-tr/hyphen-tr | libreoffice-hyphenation-tr/' debian/control.new
- # and for -l10n-fr and grammalecte
- perl -pi -e 's/myspell-dictionary-fr/myspell-dictionary-fr | libreoffice-spellcheck-fr/' debian/control.new
- perl -pi -e 's/hyphen-fr/hyphen-fr | libreoffice-hyphenation-fr/' debian/control.new
-
ifeq "$(USE_DBUS)" "y"
ifeq "$(ENABLE_BLUETOOTH)" "y"
perl -pi -e 's/paperconf$$/paperconf\n * bluez: Bluetooth support for Impress (slideshow remote control)/' debian/control.new
@@ -2617,7 +2604,16 @@ endif
install: $(STAMP_DIR)/install-common $(STAMP_DIR)/install-arch $(STAMP_DIR)/install-indep
install-common: $(STAMP_DIR)/install-common
-$(STAMP_DIR)/install-common:
+ifeq ($(MAKECMDGOALS),binary)
+$(STAMP_DIR)/install-common: $(STAMP_DIR)/build-arch $(STAMP_DIR)/build-indep
+else
+ifeq ($(MAKECMDGOALS),binary-indep)
+$(STAMP_DIR)/install-common: $(STAMP_DIR)/build-indep
+endif
+ifeq ($(MAKECMDGOALS),binary-arch)
+$(STAMP_DIR)/install-common: $(STAMP_DIR)/build-arch
+endif
+endif
dh_testdir
dh_testroot
@@ -2651,44 +2647,34 @@ endif
# we need to do it here. If -kf5 isn't built
# there's no -kf5.install generated, so dh_missing complains later
ifeq "$(ENABLE_QT5)" "y"
- if [ -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_qt5lo.so ]; then \
- mkdir -p debian/tmp/pkg/libreoffice-qt5/$(OODIR)/program; \
- mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_qt5lo.so\
- debian/tmp/pkg/libreoffice-qt5/$(OODIR)/program; \
- fi
+ mkdir -p debian/tmp/pkg/libreoffice-qt5/$(OODIR)/program
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_qt5lo.so\
+ debian/tmp/pkg/libreoffice-qt5/$(OODIR)/program
endif
ifeq "$(ENABLE_QT6)" "y"
- if [ -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_qt6lo.so ]; then \
- mkdir -p debian/tmp/pkg/libreoffice-qt6/$(OODIR)/program; \
- mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_qt6lo.so\
- debian/tmp/pkg/libreoffice-qt6/$(OODIR)/program; \
- fi
+ mkdir -p debian/tmp/pkg/libreoffice-qt6/$(OODIR)/program
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_qt6lo.so\
+ debian/tmp/pkg/libreoffice-qt6/$(OODIR)/program
endif
ifeq "$(shell echo $(ENABLE_KF5)$(ENABLE_KF6) | grep -q y && echo true)" "true"
ifeq "$(BUILD_PLASMA)" "y"
- if [ -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf$(PLASMA_VERSION)be1lo.so ]; then \
- mkdir -p debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program; \
- mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf$(PLASMA_VERSION)be1lo.so \
- debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program; \
- fi
+ mkdir -p debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf$(PLASMA_VERSION)be1lo.so \
+ debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program
# remove other ones maybe built by --enable-kfX
rm -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/libkf*be1lo.so
else
rm -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/libkf*be1lo.so
endif
ifeq "$(ENABLE_KF5)" "y"
- if [ -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_kf5lo.so ]; then \
- mkdir -p debian/tmp/pkg/libreoffice-kf5/$(OODIR)/program; \
- mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_kf5lo.so \
- debian/tmp/pkg/libreoffice-kf5/$(OODIR)/program; \
- fi
+ mkdir -p debian/tmp/pkg/libreoffice-kf5/$(OODIR)/program
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_kf5lo.so \
+ debian/tmp/pkg/libreoffice-kf5/$(OODIR)/program
endif
ifeq "$(ENABLE_KF6)" "y"
- if [ -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_kf6lo.so ]; then \
- mkdir -p debian/tmp/pkg/libreoffice-kf6/$(OODIR)/program; \
- mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_kf6lo.so \
- debian/tmp/pkg/libreoffice-kf6/$(OODIR)/program; \
- fi
+ mkdir -p debian/tmp/pkg/libreoffice-kf6/$(OODIR)/program
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_kf6lo.so \
+ debian/tmp/pkg/libreoffice-kf6/$(OODIR)/program
endif
endif
@@ -2933,11 +2919,9 @@ ifeq "$(ENABLE_JAVA)" "y"
endif
ifeq "$(ENABLE_FIREBIRD)" "y"
- if [ -f $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd ]; then \
- mkdir -p $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry; \
- mv $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd \
- $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry; \
- fi
+ mkdir -p $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry
+ mv $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd \
+ $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry
endif
ifeq "$(PACKAGE_SDK)" "y"
@@ -4079,7 +4063,7 @@ endif
touch $@
binary-arch: $(STAMP_DIR)/binary-arch
-$(STAMP_DIR)/binary-arch: $(STAMP_DIR)/install-arch debian/control $(STAMP_DIR)/maintscripts
+$(STAMP_DIR)/binary-arch: $(STAMP_DIR)/prepare $(STAMP_DIR)/build-arch $(STAMP_DIR)/install-arch debian/control $(STAMP_DIR)/maintscripts
dh_testdir
dh_testroot
@@ -4342,8 +4326,8 @@ endif
touch $@
-binary-indep: $(GSI_EXPORT_STAMP) $(STAMP_DIR)/binary-indep
-$(STAMP_DIR)/binary-indep: $(STAMP_DIR)/install-indep debian/control $(STAMP_DIR)/maintscripts $(STAMP_DIR)/langpacks
+binary-indep: $(STAMP_DIR)/binary-indep
+$(STAMP_DIR)/binary-indep: $(STAMP_DIR)/prepare $(STAMP_DIR)/build-indep $(STAMP_DIR)/install-indep debian/control $(STAMP_DIR)/maintscripts $(STAMP_DIR)/langpacks
ifneq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),$(OOO_JAVA_ARCHS)))
echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
echo "For uploads with binary-all packages, please use arches where Java is enabled"