summaryrefslogtreecommitdiffstats
path: root/lotuswordpro/Module_lotuswordpro.mk
diff options
context:
space:
mode:
Diffstat (limited to 'lotuswordpro/Module_lotuswordpro.mk')
-rw-r--r--lotuswordpro/Module_lotuswordpro.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/lotuswordpro/Module_lotuswordpro.mk b/lotuswordpro/Module_lotuswordpro.mk
new file mode 100644
index 0000000000..d7be423216
--- /dev/null
+++ b/lotuswordpro/Module_lotuswordpro.mk
@@ -0,0 +1,25 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,lotuswordpro))
+
+ifeq ($(ENABLE_LWP),TRUE)
+
+$(eval $(call gb_Module_add_targets,lotuswordpro,\
+ Library_lwpft \
+))
+
+$(eval $(call gb_Module_add_check_targets,lotuswordpro,\
+ CppunitTest_lotuswordpro_test_lotuswordpro \
+ CppunitTest_lotuswordpro_import_test \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: