summaryrefslogtreecommitdiffstats
path: root/tests/style/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/style/CMakeLists.txt')
-rw-r--r--tests/style/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/style/CMakeLists.txt b/tests/style/CMakeLists.txt
new file mode 100644
index 0000000..93d6049
--- /dev/null
+++ b/tests/style/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_test(NAME headers
+ COMMAND ${CMAKE_SOURCE_DIR}/compat/check_includes.sh ${CMAKE_SOURCE_DIR}/src/ ${CMAKE_SOURCE_DIR}/tools/lint/ ${CMAKE_SOURCE_DIR}/tools/re/)
+
+if (${SOURCE_FORMAT_ENABLED})
+ add_test(NAME format WORKING_DIRECTORY ${CMAKE_BINARY_DIR} COMMAND cmake --build ${CMAKE_BINARY_DIR} --target format-check)
+endif()
+
+# just compile
+add_executable(cpp_compat cpp_compat.c $<TARGET_OBJECTS:yangobj>)
+target_include_directories(cpp_compat BEFORE PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
+target_link_libraries(cpp_compat ${CMAKE_THREAD_LIBS_INIT} ${PCRE2_LIBRARIES} ${CMAKE_DL_LIBS} m)
+target_compile_options(cpp_compat PUBLIC "-Werror=c++-compat")