summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec
parentInitial commit. (diff)
downloadlintian-upstream.tar.xz
lintian-upstream.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec')
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/debian/rules37
-rw-r--r--t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/fill-values4
2 files changed, 41 insertions, 0 deletions
diff --git a/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/debian/rules b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/debian/rules
new file mode 100755
index 0000000..bd004e3
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+#
+# Use an alternate rules file that doesn't call dh to test not warning
+# about debhelper script tokens if we call no programs that care about
+# them.
+
+pkg = $(shell dh_listpackages)
+
+build: build-arch build-indep
+build-arch:
+build-indep:
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+binary: binary-indep binary-arch
+binary-arch:
+binary-indep:
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_install
+ dh_installchangelogs
+ dh_installdebconf
+ # dh_installdocs may modify maintainer scripts
+ install -m 644 debian/copyright debian/$(pkg)/usr/share/doc/$(pkg)
+ dh_link
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+.PHONY: build-arch build-indep build binary binary-arch binary-indep clean
diff --git a/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/fill-values b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/fill-values
new file mode 100644
index 0000000..c836ef5
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/fill-values
@@ -0,0 +1,4 @@
+Skeleton: upload-native
+Testname: debhelper-dh-clean-k-deprecated
+Dh-Compat-Level: 11
+Description: Test for debhelper >=7 packages using dh_clean -k