summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig')
-rw-r--r--t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig/config-gen.pl31
-rwxr-xr-xt/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig/gen-source.mk8
2 files changed, 39 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig/config-gen.pl b/t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig/config-gen.pl
new file mode 100644
index 0000000..e6588b7
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig/config-gen.pl
@@ -0,0 +1,31 @@
+#!/usr/bin/perl
+
+# Helper script to generate d/config from d/templates.
+# It is just here to make sure all templates are "used".
+
+use strict;
+use warnings;
+
+print <<EOF ;
+#!/bin/sh
+
+set -e
+
+. /usr/share/debconf/confmodule
+
+EOF
+
+for my $line ( <STDIN> ) {
+
+ if ($line =~ /^Template:\s*(\S+)\s*$/) {
+
+ my $template = $1;
+ next
+ unless defined $template;
+
+ print "db_input high $template || true\n";
+ print "db_go\n\n";
+ }
+}
+
+exit 0;
diff --git a/t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig/gen-source.mk b/t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig/gen-source.mk
new file mode 100755
index 0000000..f6f5975
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-missing-dep/build-spec/orig/gen-source.mk
@@ -0,0 +1,8 @@
+#!/usr/bin/make -f
+
+all: debian/config
+
+debian/config: debian/templates
+ perl config-gen.pl < $< > $@
+
+